Page MenuHomeFeedback Tracker

BIS_cooper
User

Projects

User does not belong to any projects.

User Details

User Since
Dec 19 2013, 12:26 PM (362 w, 1 d)

Recent Activity

May 10 2016

BIS_cooper added a comment to T85008: No more able to launch multiplayer subscribed missions from Steam.

HI, so if I understand it correctly you have subscribed MP mission. But you're not able to host the mission because it's not visible among other scenarios in MP screen? Or?

May 10 2016, 12:23 PM · Arma 3
BIS_cooper added a comment to T84774: Cannot upload any mission on steam worksop.

We're still unable to reproduce the issue. Could you please send us the logs (c:\Users\<username>\AppData\Local\Arma 3\*.rpt)? If possible please include also mission file your're trying to publish. Thank you.

May 10 2016, 12:16 PM · Arma 3
BIS_cooper added a comment to T84774: Cannot upload any mission on steam worksop.

hi, could you please upload arma log files (c:\Users\<username>\AppData\Local\Arma 3\*.rpt)? Where does the message appears? Directly in editor after you click publish mission button?

May 10 2016, 12:16 PM · Arma 3
BIS_cooper added a comment to T84680: Scenarios from the steam workshop cannot be started when steam is in offline mode.

Cool it worked:) And yes, please let us know about any issue:)

May 10 2016, 12:14 PM · Arma 3
BIS_cooper added a comment to T84680: Scenarios from the steam workshop cannot be started when steam is in offline mode.

Ok, seems your missing a launcher dll. Could you please do verification of local data of arma 3? (via Steam->library->arma3->RB click->properties->local files tab->verify integrity of game cache). Thank you

May 10 2016, 12:14 PM · Arma 3
BIS_cooper added a comment to T84680: Scenarios from the steam workshop cannot be started when steam is in offline mode.

Could you please upload Launcher log files?http://arma.jiripolasek.com/howtos.html
THX

May 10 2016, 12:14 PM · Arma 3
BIS_cooper added a comment to T84680: Scenarios from the steam workshop cannot be started when steam is in offline mode.

Thank you. Will get back to you after investigation;)

May 10 2016, 12:14 PM · Arma 3
BIS_cooper added a comment to T84680: Scenarios from the steam workshop cannot be started when steam is in offline mode.

"This is the same with mods, you cannot launch any mods from steam workshop when not connected to the internet..."
You means it's not possible to play with mods (after they are downloaded) when there's no internet connection? Should be totally possible. What is the game error?

May 10 2016, 12:14 PM · Arma 3
BIS_cooper added a comment to T84508: Dedicated Server needs Steam Account.

Just to keep you updated: I believe we've finally found the issue. Our QA is currently testing the solution. Should be out in dev soon:)

May 10 2016, 12:09 PM · Arma 3
BIS_cooper added a comment to T84508: Dedicated Server needs Steam Account.

The issue should be fixed in today dev update. Could you please report back if it's working for you? thx

May 10 2016, 12:09 PM · Arma 3
BIS_cooper added a comment to T84508: Dedicated Server needs Steam Account.

Found the issue. Fix is on it's way;)

May 10 2016, 12:09 PM · Arma 3
BIS_cooper added a comment to T84464: Publisher doesn't recognise already uploaded mods/missions.

Hi, thx.

I've attached new version of The Publisher. It has all logs enabled. Could you please try with it and upload new log files? BTW what mod are you trying to update?

Thank you.

May 10 2016, 12:07 PM · Arma 3
BIS_cooper added a comment to T84464: Publisher doesn't recognise already uploaded mods/missions.

ohh, yes. forgot about that. sorry for confusion.

May 10 2016, 12:07 PM · Arma 3
BIS_cooper added a comment to T84464: Publisher doesn't recognise already uploaded mods/missions.

Hi, could you please upload log file for the publisher (c:\Users\<username>\AppData\Local\Arma 3 Publisher\Logs\)? What mod are you trying to update? thx for reporting

May 10 2016, 12:07 PM · Arma 3
BIS_cooper added a comment to T84196: Binarise crash error code -1073741819..

hi, please include also binarize.mdmp and if possible the source data. Thank you.

May 10 2016, 12:00 PM · Arma 3
BIS_cooper added a comment to T84170: Bis Binarize has poor/no error reporting when binarising..

Hi, I see you're using pretty old version of binarize. Could you please try it with current version to see if the issue is still there?

May 10 2016, 11:59 AM · Arma 3
BIS_cooper added a comment to T83085: Operation Failed while uploading a mission to Steam from the in-game editor.

ok, but still I need mission files to do the update...

May 10 2016, 11:25 AM · Arma 3
BIS_cooper added a comment to T83085: Operation Failed while uploading a mission to Steam from the in-game editor.

hi, other users are experiencing this too sometimes. Unfortunately seems related to their connection and steam servers. Is it possible for you to try publish from different PC/connection?

May 10 2016, 11:25 AM · Arma 3
BIS_cooper added a comment to T83085: Operation Failed while uploading a mission to Steam from the in-game editor.

If you don't mind to upload mission files I could try it (it wont't be visible in steam and I'll delete it after publish of course).

May 10 2016, 11:25 AM · Arma 3
BIS_cooper added a comment to T82897: Arma 3 launcher crashed / stopped working mid-game.

hi, should be fixed. Currently under QA tests.

May 10 2016, 11:19 AM · Arma 3
BIS_cooper added a comment to T82768: Tools - Publisher will not start fully.

seems it's directly related to win10 version reported

May 10 2016, 11:15 AM · Arma 3
BIS_cooper added a comment to T82768: Tools - Publisher will not start fully.

hi, thanks for super info. Sorry for the delay- vacation. We'll find out the issue;)

May 10 2016, 11:15 AM · Arma 3
BIS_cooper added a comment to T82768: Tools - Publisher will not start fully.

Unfortunately we're not able to reproduce the issue. Although I've tested on win10 build 10162. have tried this build?

May 10 2016, 11:15 AM · Arma 3
BIS_cooper added a comment to T82768: Tools - Publisher will not start fully.

hi,

sorry for a long silence. Unfortuantely we're unable to reproduce the issue. Does this happen also for the Launcher? Do you have any custom dll's installed? Could you please try version in the attachement and send the logs again?

Thx,

Cooper

May 10 2016, 11:15 AM · Arma 3
BIS_cooper added a comment to T82264: Feature Request: Addon Builder.

you're welcome.
implementation done, submitted to QA for testing;)
thx for good idea:)
Cooper

May 10 2016, 10:57 AM · Arma 3
BIS_cooper added a comment to T82264: Feature Request: Addon Builder.

will do, thx

May 10 2016, 10:57 AM · Arma 3
BIS_cooper added a comment to T82264: Feature Request: Addon Builder.

released in dev branch

May 10 2016, 10:57 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

Steam bug - publishing fails sometime

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

Great it worked even that you had to create a new item.
Those are great questions and we think it's exactly how you describe it but only Valve has answers.
It's hard for us to find the exact reason since we're not able to reproduce the issue. What we see from the logs is that many queries made by the publisher are failing for some reason. It happens time to time to random users.
What we'll definitely do is to add functionality so that prev images will be shrinked/compressed so that it's size is under the 1MB limit.
Anyway thx for great collaboration:)

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

Feel free to remove it;)

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

hi, thx for the logs. It seems you are publishing preview image with size greater than 1MB. This is the limit. Could you please try to publish the item with smaller preview image? Thx

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

I've just sent a PM to your email...

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81984: Addon Updating Broken in Workshop.

hi, thx for reporting. could you please upload publisher logs? could be found in c:\Users\[username]\AppData\Local\Arma 3 Publisher\Logs\arma3publisher.rpt

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81976: Publisher doesn't work.

hi,
the temp folder should be deleted for sure. Could you plesae upload the log file? Will take a look and fix the issue. The log could be found in c:\Users\[USER]\AppData\Local\Arma 3 Publisher\Logs\
Thx

May 10 2016, 10:48 AM · Arma 3
BIS_cooper added a comment to T81895: Workshop dont update the file.

version 1.40.130473

May 10 2016, 10:45 AM · Arma 3
BIS_cooper added a comment to T81895: Workshop dont update the file.

Found it and fixed it. You could expect it in dev branch very soon (after QA testing). Also found and fixed another annoying bug where saved games were lost if the mission was updated.

May 10 2016, 10:45 AM · Arma 3
BIS_cooper added a comment to T81895: Workshop dont update the file.

Did you choose to restart the mission after the update? If there is a save for previous version and one click "continue" the game will use pbo for which the save was made. So until one chooses to restart the mission the game keeps the old version (compatible with the save). Once you choose to restart the mission gets updated. Could this be the case?

May 10 2016, 10:45 AM · Arma 3
BIS_cooper added a comment to T80838: Unable to update mission on Steam workshop.

no longer valid (steam issiue anyway)

May 10 2016, 10:11 AM · Arma 3
BIS_cooper added a comment to T80838: Unable to update mission on Steam workshop.

So does the deletion solved the issue for you? Seems like Steam Client issue. There's also issue on Steam DB that some items cannot be updated, but actual update fails in this case. Could you please also upload Steam workshop log? Could be found in usually here: c:\Program Files (x86)\Steam\logs\. PLease upload "workshop.log" and "cloud.log" files. Thx

May 10 2016, 10:11 AM · Arma 3
BIS_cooper added a comment to T80813: Binarize INT_DIVIDE_BY_ZERO.

Hi,
looking into the issue right now. Thx for reporting and for crash files. It helps a lot.
Will keep in touch;)

May 10 2016, 10:10 AM · Arma 3
BIS_cooper added a comment to T80813: Binarize INT_DIVIDE_BY_ZERO.

Could you please upload AddonBuilder log file (AddonBuilder.rpt)? It's located in Arma3Tools root dir under Logs folder usually c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\AddonBuilder.rpt

May 10 2016, 10:10 AM · Arma 3
BIS_cooper added a comment to T80437: Addon Builder Packing time.

Hi, I had a time to take a look at the issue finally.

Unfortunately from the logs everything seems fine. The "Syncing file ..." message is a result from "Whitelist" setting in Option window. This is set there: *.pac,*.paa,*.rtm,*.sqf,*.sqs,*.bikb,*.fsm,*.wss,*.ogg,*.wav,*.fxy,*.csv,*.html,*.lip,*.txt,*.bisurf,*.shp,*.dbf,*.shx,*.prj,*.cfg,*.rvmat
So those files needs to be copied to temporary folder before binarizing, packaging. With whitelist you are saying: please include those files in resulting pbo. It does not have anything to do with binarization exclude list. binarization exlude list is list of files/folder that should not be binarized. Still all files (binarized or not) will be "packed" into pbo file. If you empty your whitelist setting no sync will occur but the pbo will not work since no texture headers will be present for example.

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80437: Addon Builder Packing time.

Hi, will resolve this week. You can expect the fix in release next weeek. Thx for your patience.

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80437: Addon Builder Packing time.

Hi,
thx for the logs and your describtion. I see the issue. Will ping you when it's fixed (in a new year unfortunately).

Thx and Merry Christmas,

Jiri

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80437: Addon Builder Packing time.

hi,

thx for reporting. Could you please upload your Logs dir in Arma 3 Tools? typicaly c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\.

thx,

cooper

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80429: Half of my entries missing in "Publish on Steam Workshop" (in editor).

QA approved, reporter confirmed.

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80429: Half of my entries missing in "Publish on Steam Workshop" (in editor).

hi,
thx for reporting and sry for your troubles. The fix is under internal testing currently. Should be out in dev today.
Cooper

May 10 2016, 9:53 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

hi, thx for the logs and the video. it was really helpfull. Finally I've found the issue. There is a simple workaround for now. One needs to have "*.paa" in the whitelist option but it needs to be without a space - i.e. "*.paa" but not " *.paa". This is the reason why it's not working for you in the video. Just delete the leading space and texture headers should be created. The fix will search for paa files automaticaly (without the need of manually specified *.paa pattern) and spaces will be allowed of course. Thx again for your collaboration;)

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

I'm glad it's working for you. Fix is under internal testing now. Sorry for a stupid bug. Thx:)

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

Hi,

dev branch was updated. Please restest if the issue was solved. The version (could be find in the "About" window ) is 1.1.128499

Thx

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

Thx a lot, we currently uploading a new version with the fix:)
Will inform you when it's available;)

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

Hi,

thx for testing and your patience. Unfortunately I'm not able to find uploaded logs. Could you please reuload the log from dev build?

Thank you

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

Hi hero,

we've made an update on DEV branch yesterday. It should fix your problem. Could you please retest with DEV branch?

Thx,

cooper

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T80163: Addon Builder does not generate texHeaders.bin.

Hi, thx for reporting. could you please upload AddonBuilder log file? Should be located in arma3tools/logs, typically c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\addonbuilder.rpt

thx

May 10 2016, 9:44 AM · Arma 3
BIS_cooper added a comment to T79759: Publisher crashes when selecting a PBO.

hi, sorry for confusion. the fix is under testing now. will be released very soon. thx fot your patience

May 10 2016, 9:32 AM · Arma 3
BIS_cooper added a comment to T79723: Publisher has stopped working.

fixed. new version will be released soon. thx for providing the pbo

May 10 2016, 9:31 AM · Arma 3
BIS_cooper added a comment to T79572: ARMA 3 STEAM PUBLISHER CRASH TO DESKTOP.

hi, the issue should be fixed now. The fix will be included in next arma 3 tools update.

May 10 2016, 9:26 AM · Arma 3
BIS_cooper added a comment to T79572: ARMA 3 STEAM PUBLISHER CRASH TO DESKTOP.

hi,

ok, you have your steam library elsewere. At least this part of the path should exists somewhere in you pc: SteamApps\common\Arma 3
Tools\Logs\Publisher.rpt. Location of the steam library dir could be found in Arma 3 Tools properties in Steam client. Run/open Steam -> library -> tools->arma 3 tools -> right click -> properties -> local files tab -> browse local files. explorer will open and you should be able to find Logs dir with Publisher.rpt file.

Thx

May 10 2016, 9:26 AM · Arma 3
BIS_cooper added a comment to T79572: ARMA 3 STEAM PUBLISHER CRASH TO DESKTOP.

Hi,
could you please upload log file?
Should be located here: c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\Publisher.rpt

Thank you.

May 10 2016, 9:26 AM · Arma 3
BIS_cooper added a comment to T79384: Publisher fails to update Steam Workshop entry.

Hi, whats the name of the item you're trying to update. It's a inconsistency in Steam backend DB. Fortunately Valve is able to fix it per item.

May 10 2016, 9:20 AM · Arma 3
BIS_cooper added a comment to T79384: Publisher fails to update Steam Workshop entry.

hi, sorry for your troubles. unfortunately we're still unable to reproduce the issue. Our QA is testing this every day (using your pbo) but it's ok every try. it really seems there's an issue on steam releated directly to your specific conditions. we'll keep you updated if anything new arise

May 10 2016, 9:20 AM · Arma 3
BIS_cooper added a comment to T79072: The publisher tools create addon like Arma 3 tool ( like a tool) (STEAM ISSUE).

Fix for this will be released tomorow with stable version. It will work all three ways then. thx for workaround and sorry for troubles,

Jiri

May 10 2016, 9:08 AM · Arma 3
BIS_cooper added a comment to T78909: The addon Publisher does not display my uploaded items on Steam.

Hi,

sorry for taking so long but it's fixed. it will be released tomorow with stable version.

thx,

Jiri

May 10 2016, 9:04 AM · Arma 3
BIS_cooper added a comment to T78893: Publisher crash.

hi, thanks for the log.

From them it seems you are running stable version of publisher. Is this so?

There is a new version of the publisher if you switch to the developement branch (right click on Arma 3 tools->properties->betas->select developement from the first combo).
You need to start it directly via exe, not through arma 3 tool (will be fixed with upcoming stable update). Just navigate to install dir of arma 3 tools (typically c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Publisher) and launch Publisher.exe file.

Hope it helps;)

May 10 2016, 9:03 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

we've updated the builder around 14 so the fix is was already there when you're trying it I guess. Anyway I'm glad it works ok for you:) THX

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

Thanks for the log.
Issue is fixed. We'll update the developement branch today.
Will keep you up to date.

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

Weird. I'm not able to reproduce. Could you please upload log file (c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\AddonBuilder.rpt)?

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

Hi, update should be done today (it went wrong yesterday). Will update you once it's done. Thx

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

hi, updated. Fix is there (tested my self).
Thanks for your patience

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78747: [urgent] packing with namespace deletes source files.

I'm really sorry for your troubles. Issue is fixed now. Should be released next week. Sorry once again for this stupid bug.

May 10 2016, 8:59 AM · Arma 3
BIS_cooper added a comment to T78561: The launcher will not open.

ok, please uploud the logs once again if present:
c:\Users\[username]\AppData\Local\Arma 3 Launcher\Logs\arma3launcher.rpt
and
c:\Users\[username]\AppData\Local\Arma 3 Launcher\Logs\SteamServiceHost.rpt

There could be also crash minidump file located in:c:\Users\cooper\AppData\Local\Arma 3 Launcher\arma3launcher_2014...mdmp
Please upload it too.

Thanks a lot

May 10 2016, 8:54 AM · Arma 3
BIS_cooper added a comment to T78561: The launcher will not open.

Thanks for the log. Unfortunately everything looks fine in it.
Could you please post a list of files under "[arma 3 install dir]\Launcher" dir? Steam client sometime fails to download all files.

Thanks a lot.

May 10 2016, 8:54 AM · Arma 3
BIS_cooper added a comment to T78561: The launcher will not open.

thanks for the shot. There was an update of stable release (you need to switch arma back to NONE in betas) of the launcher yesterday. Does it work for you?

May 10 2016, 8:54 AM · Arma 3
BIS_cooper added a comment to T78561: The launcher will not open.

hi,

could you please paste logs here?
It could be found in c:\Users\[username]\AppData\Local\Arma 3 Launcher\Logs\

Thx

May 10 2016, 8:54 AM · Arma 3
BIS_cooper added a comment to T78452: Addon builder not binarizing rtm animation properly.

Ok, now I have a repro. Thx. Will update you once I find out the reason for the issue.

May 10 2016, 8:52 AM · Arma 3
BIS_cooper added a comment to T78452: Addon builder not binarizing rtm animation properly.

Hi, I'm sorry, but i'm not able to reproduce it (wrong data). I've followed your steps but it's working fine for me. Could you please try to use it in your installation? Pbo is in the atachment. Maybe there is a difference. Let's see. Thx.

May 10 2016, 8:52 AM · Arma 3
BIS_cooper added a comment to T78452: Addon builder not binarizing rtm animation properly.

Thx a lot for detailed report. Have a working repro so I should find the answer;)

May 10 2016, 8:52 AM · Arma 3
BIS_cooper added a comment to T78452: Addon builder not binarizing rtm animation properly.

Could you please upload animation you are using along with model.cfg and logs (c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\AddonBuilder.rpt). Thx

May 10 2016, 8:52 AM · Arma 3
BIS_cooper added a comment to T78440: no mods and addons showup in launcher.

Hi, sry it's still not working for you. We're trying to solve the issue. Unfortunately we're unable to reproduce it on our side. Could you please send us fresh logs using the latest version of the launcher? There will be big update of the launcher in dev branch next week. So hopefully it would fix the problem. Will let you know once it's out so you could retest. Thx for your patience and collaboration

May 10 2016, 8:51 AM · Arma 3
BIS_cooper added a comment to T78440: no mods and addons showup in launcher.

Hi,

could you please try to subscribe this: http://steamcommunity.com/sharedfiles/filedetails/?id=333310405
and see if it's visible in the launcher?

Are you sure you are subscribing to addons? I.e. not scenarios/missions? Those items has addon or mod tag assigned instead of scenario tag. Only those are visible in the launcher.

Thx,

Jiri

May 10 2016, 8:51 AM · Arma 3
BIS_cooper added a comment to T78440: no mods and addons showup in launcher.

seems there is process isolation problem between launcher and steam client. could you please try to launcher both (steam client and launcher) as admin? thx

May 10 2016, 8:51 AM · Arma 3
BIS_cooper added a comment to T78440: no mods and addons showup in launcher.

hi, could you please try to switch Arma to the developement branch?

May 10 2016, 8:51 AM · Arma 3
BIS_cooper added a comment to T78440: no mods and addons showup in launcher.

Hi, there was a major update recently. Does the issue still persist? Does it work in dev branch?

May 10 2016, 8:51 AM · Arma 3
BIS_cooper added a comment to T78054: Failed to open launcher.

.NET 4.5.1 installer added

May 10 2016, 8:41 AM · Arma 3
BIS_cooper added a comment to T77623: Addon Builder has deleted my entire modfolder.

I'm really sorry for your troubles. Issue is fixed now. Should be released next week. Sorry once again for this stupid bug.

May 10 2016, 8:30 AM · Arma 3
BIS_cooper added a comment to T77539: AddonBuilder commandline fails to pack completely.

thanks for pointing this out. the parameter names need to be lower case now. sorry for confusion. I've already corrected help text.

Regarding the prefix and project, this is a know issue and it's fixed by now. will be part of next update

May 10 2016, 8:28 AM · Arma 3
BIS_cooper added a comment to T77539: AddonBuilder commandline fails to pack completely.

just a execution command needs to be changed and it should work properly

May 10 2016, 8:28 AM · Arma 3
BIS_cooper added a comment to T77539: AddonBuilder commandline fails to pack completely.

command needs to be in this form:

AddonBuilder.exe "p:\rhsafrf\.." "k:\Steam\..." -packonly -clear -prefix="rhsafrf\addons\..." -project="p:\rhsafrf" -sign="k:\developement\..." etc.

So basicaly equal sign must follow any parameter whitch is not switch param (i.e. it's a value parameter). There is a nice example in help(AddonBuilder.exe -help).

if you still have questions just ask:)

May 10 2016, 8:28 AM · Arma 3
BIS_cooper added a comment to T77368: AddonBuilder won't start: "Steam client is not running" (It is).

VS 2012 redist. will be installed during installation of the tools

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77368: AddonBuilder won't start: "Steam client is not running" (It is).

Could you please try to install this if it solves the problem? http://www.microsoft.com/en-us/download/details.aspx?id=30679

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77367: Namespace changes cause Bin config error in tools folder.

fixed meanwhile

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77367: Namespace changes cause Bin config error in tools folder.

Hi, will close this issue. Are those problems mentioned above reported? If no could you please create new issue for them? Thx

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77367: Namespace changes cause Bin config error in tools folder.

Hi, is this still happenning to you? thx

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77367: Namespace changes cause Bin config error in tools folder.

could you please paste/upload the log? will be very useful. thanks

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

project path in options window to rescue. this defined dir used to search for includes in config files. so in your case it should point to arma 3 root

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

from the log I see you are gettring error during config convert. seems there is a bug in "C:\Program Files (x86)\Steam\SteamApps\common\Arma 3\@FETT_Test\addons\FatTrack\config.cpp" file. Maybe wrong project dir? It needs to poinnt to the root of include files used in the config.cpp

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

hi,

could you please upload your log file (c:\Program Files (x86)\Steam\SteamApps\common\Arma 3 Tools\Logs\AddonBuilder.rpt)?

Thx

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

The status is actually a log and it's configured in the same logger.xml file. Please make sure you have these lines there (present in original xml):

<?xml version="1.0"?>
<log4net>

...

<appender name="StatusAppender" type="AddonBuilder.StatusAppender">

<layout type="log4net.Layout.PatternLayout">
  <conversionPattern value="%message%newline" />
</layout>

</appender>

<logger name="user" additivity="false">

<level value="INFO" />
<appender-ref ref="UserConsole" />
<appender-ref ref="UserRollingFile" />
<appender-ref ref="StatusAppender" />

</logger>

...

</log4net>

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

@TomNedry: thanks for the log. the issue is fixed. we're gonna test it internally before update.

@deanosbeano: this line "<file value="AddonBuilder.log" />" specifies log locatation. so in your case it should look like this: <file value="LOGS\AddonBuilder.log" />
or this: <file value="P:\LOGS\AddonBuilder.log" />

May 10 2016, 8:25 AM · Arma 3
BIS_cooper added a comment to T77361: AddonBuilder error since latest release: "Build failed. Result code=1".

Fixed. Submitted for internal testing

May 10 2016, 8:25 AM · Arma 3