Page MenuHomeFeedback Tracker

HeroesandvillainsOS
User

Projects

User does not belong to any projects.

User Details

User Since
Nov 1 2015, 8:36 PM (229 w, 5 d)

Recent Activity

Dec 14 2017

HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.

@Wulf oh hey I forgot I had put a client rpt showing the Documents error on my Dropbox 4 days ago when Yxman was helping me out:

Dec 14 2017, 2:18 AM · Arma 3

Dec 13 2017

HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.

@Wulf Only last night was I able to get Windows running properly. Now I need to download the game again, then make some profile changes (I have no choice honestly. My keyboard doesn’t have a number pad, so I can’t leave it on default settings), then give it a day or two to see if Arma stops communicating with my Documents. I’m actually kind of hoping even with the fresh OS and game install I’m able to replicate this, that way it can be fixed before development on the game fully ceases.

Dec 13 2017, 5:48 PM · Arma 3

Dec 12 2017

HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.

Ha now my internet won’t work after reinstalling Windows 10. Lol. Man the stuff I do for this game. I’ll be back if I can ever figure this out. Stay tuned.

Dec 12 2017, 11:29 PM · Arma 3
HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.

Can I get this reopened? It’s not solved. The problem is back even though it was working for a few hours the other day just fine. This was with a fresh account on my PC, a fresh game install, and brand new Documents folder and brand new game profile as well (I did not copy/paste any old files this time).

Dec 12 2017, 11:25 PM · Arma 3
HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.
Dec 12 2017, 11:18 PM · Arma 3
HeroesandvillainsOS added a comment to T127321: Profiles stopped being recognized in game.

I want to thank Yxman for taking the time to assist me here via Steam chat. So the issue apparently was Arma suddenly not being able to read or write or see my Arma 3 Documents folders, as seen in the client rpt.

Dec 12 2017, 11:17 PM · Arma 3
HeroesandvillainsOS created T127321: Profiles stopped being recognized in game.
Dec 12 2017, 11:08 PM · Arma 3

May 3 2017

HeroesandvillainsOS created T124680: setunitpos "UP" causes units to get stuck in lowering/raising weapon loop (vanilla repro mission inside).
May 3 2017, 2:45 AM · Arma 3

Mar 17 2017

HeroesandvillainsOS added a comment to T122322: [DEV] Module option-selection broken if a dropdown-box is used on the third or fourth "slot".

This issue is not resolved. For example, using the ALiVE mod in 1.68, 64-bit, the Military Commander Military Objective module dropdowns for Objective Size Filter don't appear, and it's forever stuck on "Ignore Small Objectives." The other options, of which there are several, do not show up because the dropdown list can't open.

Mar 17 2017, 4:19 PM · Arma 3

Jan 1 2017

HeroesandvillainsOS added a comment to T120361: Grass LOD pop-in problem.

Just wanted to say I see the exact same thing too, as well as several others:

Jan 1 2017, 8:47 PM · Arma 3

Oct 24 2016

HeroesandvillainsOS added a comment to T119557: Mission depedencies created by unused, only loaded mods (EDEN, SAVEGAMES).

Thanks a lot for opening this ticket. 1.60 seemed to make mods loaded in the mod line, even when not used directly in the mission itself (such as ASR_AI, and client side addons such full screen night vision, etc) dependencies when before 1.60, that would never happen.

Oct 24 2016, 6:25 PM · Arma 3

May 25 2016

HeroesandvillainsOS created T116770: Stepping on lit campfire causes a permanent red damage screen.
May 25 2016, 4:45 PM · Arma 3

May 10 2016

HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

Just an update:

After deleting everything in my MP missions folders in My Documents, the ARMA 3 root and the local appdata folders, the CTD has finally stopped. Thanks guys.

I'm now adding missions back on a "what I'm currently using" basis. Still haven't found which mission was causing the issue, but it is indeed fixed.

I have to still say that launching a vanilla game with no mods should not force the client to have to have every mod enabled for every mission in their mission folder just to host LAN. This has got to be a bug.

Anyway, problem solved.

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

Also, Killswitch posed a possible solution which I'll try too:

Try this:

  1. Make copy of the Arma 3 MPMissions folder (C:\Program Files\Steam\steamapps\common\Arma 3\MPMissions) somewhere safe.
  2. Delete all files from the Arma 3 MPMissions folder (C:\Program Files\Steam\steamapps\common\Arma 3\MPMissions)
  3. Start Arma again
  4. Try to launch a hosted LAN MP server and see if it works without crashing

If that works, you have a MP mission file that does this in the description.ext (or a file included in description.ext):
#include "\x\cba\addons\main\script_macros.hpp"
...for some unknown reason. The fix is to find and remove that mission.

And I want to thank you Commy from the bottom of my heart, man. You've invested more time in this than even Bohemia at this point and it will not be forgotten. Thanks so much.

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

Here's another report: http://pastebin.com/99qQkgYU

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

Will I lose anything by doing this?

I guess one part of this that is really confusing for me is that I have two very specific error messages that I've shared here. Do they not point us in any direction at all? I just am really confused why "Include file x\cba\addons\main\script_macros.hpp not found" and "Unable to INIT DXGI" aren't helping point us in a direction.

Obviously the game is looking for and not finding this CBA macros script. Does anyone know what that is?

And DXGI relates to my graphics card, correct? Could that be the problem?

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

I'll post another report later tonight. In the meantime, should I delete the (now empty) Campaigns folder? I take it it's not used for anything?

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

I'm a little unclear by these instructions. The game is crashing. That's why I started this ticket.

Could you be a little more clear. The second I click on OK after selecting LAN/Internet I immediately CTD with the error messages provided in this thread.

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

I already did that. Sorry guys. The issue still persists.

Have no idea how that got there. Someone over in the CBA thread told me to remove that too. I did and the exact same error happens in the exact same manner.

Would you like a new report?

EDIT: I see now that I did put the PBO there per the author's instructions. Regardless, the issue persists. Thanks for the suggestion.

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.

Here's a new rpt with no mods enabled: http://pastebin.com/Gv172mEk

May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS edited Steps To Reproduce on T85736: "Include file x\cba\addons\main\script_macros.hpp not found" and arma3.exe not launching.
May 10 2016, 12:46 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Yes the menu was still corrupted without mods. This is what is most baffling to me. The only way I was able to make that problem go away was to unsubscribe to all the mods and verify my game cache.

Even without any mods in my launcher, the menu still looked like that. I had to unsubscribe/verify game cache to make the problem go away.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Here's a BIS forums link with a photo of what my main menu now looks like: https://forums.bistudio.com/topic/187632-main-menu-says-arma-2-and-looks-like-something-out-of-the-90s/?p=2972022

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

And now my game's main menu looks like something out of the early 90's and says ARMA 2. There's just a basic white screen with simple interfaces. I take it my game install corrupted too in the process. All because I pressed play on steam to launch the game.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

The mods themselves are what becomes corrupted. I'm obviously not an expert on this but here is what I believe is happening.

I launch Steam and press play on ARMA. This opens your launcher. Normally what happens next is the launcher looks to make sure all my mods are up-to-date.

What's sometimes happening, as I've outlined here, is that sometimes when the launcher starts, EVERY single one of Workshop subscribed mods begin to start "updating." Or rather, they all begin to redownload.

As you can imagine this can take a very long time to finish.

When this has happened to me, twice now in fact, every single one of my Workshop mods become unusable. Every single one. What I don't understand is why these Workshop mods are even updating to begin with. On the night this happened last, none of the mods had received updates since the last time I had played, therefore, why are any of them updating? Let alone all of them.

Under normal circumstances, when a mod updates, that specific mods will do what I described but it's painless and everything works afterward. But twice now my launcher has decided they EVERY single one of my mods need updating, and when that happens, EVERY single one becomes corrupted.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

I appreciate everything Wizard. I guess at this point there's not much else we can troubleshoot. The issue clearly isn't happening anymore and thanks for the time you put into this.

Happy holidays.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

This is still happening. I can't believe this.

Right now Leights OPFOR Pack, ACE, Massi's African Conflict, CUP Core, CUP Maps, CUP Units, CUP Vehicles, CUP Weapons, Kunduz Afghanistan, Massi's Middle East Warfare, Massi's NATO Russian Vehicles, Massi's NATO Russion Weapons, Resist, Massi's Russian GRU, Spyder Addons, and TRYK's Multi-Play Uniforms Pack are all "working" with the green play sign next to their name. Meaning they're all "updating."

Zombies and Demons, Gorgona, CUP ACE compatibility Addon, ARES and the 101 Editor all say "updated." Though none of them updated today.

The last time this happened to me EVERY SINGLE ONE of my mods became corrupted and needed to be redownloaded. EVERY single one. That's 21 mods now ruined just because I pressed play in Steam. All of them are now corrupted.

This launcher is too unreliable. This sets me back hours and hours and hours and bandwidth isn't free. I'll have to delete and redownload every single one now.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

So just run it, let the launcher synchronize, run it again and post whatever file pops up on my desktop back here?

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Thanks Wizard. I uploaded two files. One by running the program after unpacking it, the other after opening and letting the launcher sync.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Thanks Wizard. I'm not really very tech savvy which is why I'm opening my first ticket. I have no idea why several of my mods need resubscribing.

Would the same thing be true about Massi's NATO Russian Weapons and Massi's NATO Russian Vehicles as you see with Kunduz? Like everything is A-ok?

I obviously don't know how the logs work, but does any trace of my ARMA 3 on-screen crash messages show up in the files I sent you at all?

These are just three of what I believe to be around 10 mods that will ultimately cause my game to crash at some point (I have a lot of mods). These are just the ones I tried and were also ones that wouldn't fully load a few days ago when I had to force the Launcher to close.

Let me know if there's any more information I can provide you. And thanks for looking into this.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

And just to be clear since we're using Kunduz as an example. You see on your end of successfully loaded all data on 12/8 but it caused crashes on 12/9 and 12/10 until I decided to unsubscribe/resubscribe.

I wonder why the logs don't show this?

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Sorry, I'm new to this. I just posted the entire zip file. The dates in question should be between 12/9 (late at night) and right now (12/11 early morning0.

For instance, I just had another CTD. This one was caused by Massi's NATO Russian Weapons in an error message. The second I unsubscribed and resubscribed, the game launched successfully.

That's three separate errors now (Massi Weapons, Massi Vehicles, and Kunduz). I'm sure ther's more, I've just yet to try the mods at this point.

Let me know if you need anything else and thanks for looking into it, Wizard.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS added a comment to T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..

Unsubscribing and resubscribing to both Massi's NATO Russian Vehicles and Kunduz Afghanistan allow the game to launch properly. I think it's exactly as I had suspected and that my mods aren't properly syncing when launching the launcher through steam.

Although technically this issue is resolved, I haven't tried launching a good portion of my mods (so it probably will happen again) and hopefully I'll be lucky enough to be able to decipher the error messages enough to know which mod isn't loading correctly.

Hopefully your team can figure out why the launcher is saying mods are up-to-date when they clearly are corrupted and need unsubscribing/resubscribing through Workshop.

May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS edited Steps To Reproduce on T85338: Game crashes to desktop after splash screen. Error messages/Workshop Mods..
May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS edited Steps To Reproduce on T85337: Game crashes to desktop after splash screen. Error messages/Workshop Mods..
May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS edited Steps To Reproduce on T85336: Game crashes to desktop after splash screen. Error messages/Workshop Mods..
May 10 2016, 12:35 PM · Arma 3
HeroesandvillainsOS edited Steps To Reproduce on T85335: Game crashes to desktop after splash screen. Error messages/Workshop Mods..
May 10 2016, 12:34 PM · Arma 3