Page MenuHomeFeedback Tracker

ChuWie
User

Projects

User does not belong to any projects.

User Details

User Since
Sep 4 2014, 10:49 PM (249 w, 4 d)

Recent Activity

May 10 2016

ChuWie added a comment to T82664: Holding ctrl while sprinting makes you infinite sprint.

As mentioned, I tested it on stable branch.
I will take some time later today and will test it on dev branch as well.

May 10 2016, 11:11 AM · Arma 3
ChuWie added a comment to T82664: Holding ctrl while sprinting makes you infinite sprint.

Ok, I could test it quicker than expected.

I can confirm all the issues/exploitation mentioned in this ticket have been successfully solved in the Dev build (tested with v1.49.131774)

  • Character can no longer infinite sprint w/o taking a rest
  • can no longer run full speed uphills
  • can no longer run under seabed

Marvelous, thanks BI !!

May 10 2016, 11:11 AM · Arma 3
ChuWie added a comment to T82664: Holding ctrl while sprinting makes you infinite sprint.

It got fixed partially.
I'm no longer able to reproduce running in a seabed on stable branch, however one of the initial concerns of this ticket still persist as exploitable in the current stable branch 1.48

"Holding ctrl while sprinting makes you infinite sprint"
"Holding down ctrl and sprinting makes you able to sprint up hills"

May 10 2016, 11:11 AM · Arma 3
ChuWie added a comment to T82664: Holding ctrl while sprinting makes you infinite sprint.

This bug/exploit should get some higher priority now Adam, since it's getting more and more abused by the community in competitive servers such as Battle Royale Mod, Epoch, KoTH, etc.

https://www.youtube.com/watch?v=ZD-tlxXpZF8

Fix please Bohemia!

May 10 2016, 11:11 AM · Arma 3
ChuWie added a comment to T82515: Increased amount of floating objects in near distances [MP].

I'm aware of the setTerrainGrid function of multiplayer. Still, this has not been much of an issue on medium ranges before the newest update rolled out.
I doubt that every serveradministrator changed their 'setTerrainGrid' alltogether.

May 10 2016, 11:05 AM · Arma 3
ChuWie edited Steps To Reproduce on T82515: Increased amount of floating objects in near distances [MP].
May 10 2016, 11:05 AM · Arma 3
ChuWie added a comment to T82182: Crashing when attempting to save a game [SP].

Couldn't reproduce it without mods.
Is there anything helpful in the already provided crash reports that I attached, to narrow down the cause?

May 10 2016, 10:54 AM · Arma 3
ChuWie edited Steps To Reproduce on T82182: Crashing when attempting to save a game [SP].
May 10 2016, 10:54 AM · Arma 3
ChuWie added a comment to T81877: 142RC - DOF bug still present for scopes.

It doesn't have anything to do with my resolution which is 1920 x 1080.
Try my reproducing steps and you will understand this bug.

May 10 2016, 10:44 AM · Arma 3
ChuWie edited Steps To Reproduce on T81877: 142RC - DOF bug still present for scopes.
May 10 2016, 10:44 AM · Arma 3
ChuWie edited Steps To Reproduce on T81876: 142RC Error reload animation for LMGs.
May 10 2016, 10:44 AM · Arma 3
ChuWie edited Steps To Reproduce on T81875: 142RC VR - Missing Marksmen Symbol/Icon for NATO Laser Designator.
May 10 2016, 10:44 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

I tried this already which didn't fix it.

However, finally I've figured where the issue for me is/was;

In the past I used Fred41's custom TBB allocator (tbbmalloc).
With his little tool "LPManager" I could easily set the right privileges and apply the GMF tweak via checkbox ('UseLargePages' = 1, for key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\arma3.exe]).

Arma 3 works just fine again when unchecked "LP ImageFileMapping Client" in LPManager.exe Tool or by doing it manually via regedit and use "UseLargePages' = 0"

Found some interesting posts after a bit of research regarding this issue :

http://forums.bistudio.com/showthread.php?163640-Arma3-and-the-LARGEADDRESSAWARE-flag-(memory-allocation-gt-2GB)&p=2858167&viewfull=1#post2858167

http://forums.bistudio.com/showthread.php?177454-a-simple-registry-tweak-for-increased-performance&p=2859729&viewfull=1#post2859729

-------------

Thanks for your time Adam and your attempt to help :)
Can be closed/marked as solved.

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

I'm sorry but *.rpt files are the only ones that are created in this folder.

http://i.imgur.com/HxFmDjv.jpg

I packed all the logfiles shown on the picture in an additional .rar file called "Arma 3 logs picture all.rar" and attach them here.

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

Re-/producing steps:

  • clean startup parameters, no mods, nor any parameters
  • deleted arma3.cfg
  • game started after the 4th time of launching via ArmA3Sync (logfile attached "arma3_2015-04-02_11-39-25.rpt")
  • replaced arma3.cfg with my old own arma3.cfg
  • game still starts every 1st try
  • launched via ArmA3Sync with parameters (-maxvram=1280

-maxMem=4096 -noPause -exThreads=7 -enableHT -nosplash -world=empty) [logfile "arma3_2015-04-02_11-55-09"]

  • game still starts every 1st try
  • launched via ArmA3Sync with parameters and mods [logfile "arma3_2015-04-02_11-59-13"]
  • game still starts, 2 times it worked, then stopped working and didn't launch anymore out of 10+ tries. [logfiles weren't created at fail start for each 10+ tries since]
  • unselected all mods and tried launch, doesn't work
  • unselected all startup parameters as well, so no mods, no parameters at all, doesn't work
  • after 15th-20th try of launching following windows error "Arma 3 doesn't work anymore". Windows created logfiles in the temp folder. Attaching them in case they might be useful. ["Windows error logs.rar"]
May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

I got to look up the internally windows reports that my OS got collected w/o giving out any error messages when Arma 3 just closed.

Most of the errors are like this:

--------------------------

Name der fehlerhaften Anwendung: arma3.exe, Version: 1.40.129.533, Zeitstempel: 0x54f47474
Name des fehlerhaften Moduls: KERNELBASE.dll, Version: 6.1.7601.18409, Zeitstempel: 0x53159a86
Ausnahmecode: 0x406d1388
Fehleroffset: 0x0000c42d
ID des fehlerhaften Prozesses: 0x1188
Startzeit der fehlerhaften Anwendung: 0x01d06cc3d679f806
Pfad der fehlerhaften Anwendung: E:\SteamLibrary\steamapps\common\Arma 3\arma3.exe
Pfad des fehlerhaften Moduls: C:\Windows\syswow64\KERNELBASE.dll
Berichtskennung: 145dcf4c-d8b7-11e4-97bc-1c6f6591cfcf

--------------------------

only 1 time it's this:

Name der fehlerhaften Anwendung: arma3.exe, Version: 1.40.129.533, Zeitstempel: 0x54f47474
Name des fehlerhaften Moduls: ntdll.dll, Version: 6.1.7601.18247, Zeitstempel: 0x521ea8e7
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0005b263
ID des fehlerhaften Prozesses: 0x17a0
Startzeit der fehlerhaften Anwendung: 0x01d06cbd9281220b
Pfad der fehlerhaften Anwendung: E:\SteamLibrary\steamapps\common\Arma 3\arma3.exe
Pfad des fehlerhaften Moduls: C:\Windows\SysWOW64\ntdll.dll

Berichtskennung: d0674355-d8b0-11e4-97bc-1c6f6591cfcf

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

I packed couple of logfiles in a .rar file and uploaded them.

I tried launching with and w/o mods, trying couple of different allocators, tried running with and without command line parameters such as "-benchmark -winxp"(if they are still useful) and the ones listed in the logfiles, launching through BI launcher, launching through ArmA3Sync.

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

Today it decided to work just after the 4th try. Log file attached.

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

Arma 3 log file uploaded.
(Game decided to finally start after 1+ hr of trying. After PC restart it stopped working again and the game didn't load.)

  • no mods activated
  • tried with and without command line parameters
May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

DxDiag uploaded.

Still can't play the game since the PC restart.
Arma3.exe opens for 5 seconds in the taskmanager, then closes w/o any error messages.

May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T81821: Game crash at launch.

Just restarted my PC after it was working in the middle of filling the ticket. Result, not working again.
Uploaded a logfile of the BI ArmA 3 Launcher, maybe it can help.

May 10 2016, 10:43 AM · Arma 3
ChuWie edited Steps To Reproduce on T81821: Game crash at launch.
May 10 2016, 10:43 AM · Arma 3
ChuWie added a comment to T78701: ARMA 3 Launcher isn't displayed.

I (still) have the same problem as described by Von_Emmy.

Even in the newest sitrep#00074 mentioned troubleshooting page couldn't solve my problem.

All necessary packages are installed.

  • Do you have UAC (User Account Control) enabled on your computer?

No.

  • Are you administrator on your computer?

Yes.

  • Do you run the Steam or the ARMA as administrator?

Launching Steam or Arma or launcher or all of them as admin doesn't make any difference.

  • Are you participating in the Steam Beta?

No.

Running stable branch at the moment.

Launcher has never worked for me.

Arma 3 launches flawless though.

Holding CTRL + Shift in order to bring up the launcher in safe mode does nothing.

Launching parameters for the launcher such as -safemode and-nohwa does nothing either.

The launcher window still keeps being invisible with just the icon on the taskbar, when hovering over it, it shows me the the window border of it. When hovering above the invisible window with my mouse, the Arma mouse appears.

Will include logs from arma launcher and dxdiag into a package called "chuwie-logs.zip"

May 10 2016, 8:58 AM · Arma 3
ChuWie added a comment to T78701: ARMA 3 Launcher isn't displayed.

I can confirm that SweetFX was my issue as well *facepalm/me*

Removing SweetFX made the launcher visible.
Who would have thought that it modifies the launcher as well, or; Who would assume that it doesn't might modify the launcher as well when it's already in the same folder. I feel somewhat embarrassed now.. :D

Thanks sc_neo for reporting! Thanks BIS Wizard for the quick response and sorry for wasting your time since my issue was clearly not Arma side (at least on my PC, maybe the others in this ticket still have the issue because they don't even run sweetFX and hence the problem is elsewhere. If that is the case then all the best that you can fix it soon).

Nevertheless, keep rocking BIS, loving ArmA!

May 10 2016, 8:58 AM · Arma 3
ChuWie added a comment to T77184: Arma 3 Mouse is not Locked to one Screen.

Related to this:
http://feedback.arma3.com/view.php?id=5076

May 10 2016, 8:21 AM · Arma 3
ChuWie added a comment to T77184: Arma 3 Mouse is not Locked to one Screen.

I'm almost glad to see I'm not the only one with that problem.
It's a really annoying issue that leads to the game minimizing and accidentally clicking on another window on another monitor.

I could observe strange mouse movement behavior when doing this:

With these steps I can reproduce the error easily in no time (min. 2 Monitors needed to reproduce):

  • Load a game/any map/scenario, open your soldiers inventory with I(i) button
  • mouse should appear in the center of the monitor the very 1st time
  • move mouse slightly (not persistent) any direction, close inventory again with I button
  • open inventory again, don't move this time
  • close inventory again, and open it up again
  • now every time you close/-re enter inventory the mouse will shift further.
  • repeat every direction you want, when it goes towards the direction of the other monitor it's when the game minimizes because the mouse is out of bound of the game's monitor.

I found a tool that will lock the mouse to the active monitor, even got a profile management, so the mouse can just be locked to active screen while Arma 3 is the active window:

http://sourceforge.net/projects/mousenitor

For now a good solution to me until BI will fix this issue.
Hope I could help in any way, cheers :)

May 10 2016, 8:21 AM · Arma 3
ChuWie added a comment to T63442: Mouse clipping to fullscreen.

I'm almost glad to see I'm not the only one with that problem.
It's a really annoying issue that leads to the game minimizing and accidentally clicking on another window on another monitor.

I could observe strange mouse movement behavior when doing this:

With these steps I can reproduce the error easily in no time (min. 2 Monitors needed to reproduce):

  • Load a game/any map/scenario, open your soldiers inventory with I(i) button
  • mouse should appear in the center of the monitor the very 1st time
  • move mouse slightly (not persistent) any direction, close inventory again with I button
  • open inventory again, don't move this time
  • close inventory again, and open it up again
  • now every time you close/-re enter inventory the mouse will shift further.
  • repeat every direction you want, when it goes towards the direction of the other monitor it's when the game minimizes because the mouse is out of bound of the game's monitor.

I found a tool that will lock the mouse to the active monitor, even got a profile management, so the mouse can just be locked to active screen while Arma 3 is the active window:

http://sourceforge.net/projects/mousenitor

For now a good solution to me until BI will fix this issue.
Hope I could help in any way, cheers :)

May 10 2016, 12:40 AM · Arma 3
ChuWie added a comment to T63442: Mouse clipping to fullscreen.

Related to this:
http://feedback.arma3.com/view.php?id=18826

May 10 2016, 12:40 AM · Arma 3

May 9 2016

ChuWie added a comment to T58529: Left CTRL Key in Helicopter always changes View.

Please fix Bohemia!

May 9 2016, 3:19 PM · Arma 3