Page MenuHomeFeedback Tracker

ViperMaul
User

Projects

User does not belong to any projects.

User Details

User Since
Mar 6 2013, 12:48 AM (324 w, 3 d)

Recent Activity

May 30 2016

ViperMaul added a comment to T80491: Some .bikey file combinations prevent dedicated server from loading.

This should probably be resolved as fixed and closed.

May 30 2016, 1:29 AM · Arma 3

May 10 2016

ViperMaul added a comment to T80491: Some .bikey file combinations prevent dedicated server from loading.

Looks like they made some changes in Dev Branch 1.46 regarding this. Is this still a problem there?
Re: Fixed: Server issue when using a larger list of BIKEY signature files
Source: http://forums.bistudio.com/showthread.php?149636-Development-Branch-Changelog&p=2939180&viewfull=1#post2939180

May 10 2016, 9:55 AM · Arma 3
ViperMaul added a comment to T80491: Some .bikey file combinations prevent dedicated server from loading.

It looks like it may indeed be fixed
Reference: http://forums.bistudio.com/showthread.php?178224-CBA-Community-Base-Addons-ARMA-3&p=2948723&viewfull=1#post2948723

Thanks

May 10 2016, 9:55 AM · Arma 3
ViperMaul added a comment to T77091: AH-99 Blackfoot optics won't work..

Hopefully this information will be helpful...

The following video was submitted by gienkov on May 7th.
"After last ArmA 3 update all helicopters optics are gone, you only get zoomed screen from gunner seat but it's a no go that way..."

Reference: https://www.youtube.com/watch?v=9VNgOOSaZYM&feature=youtu.be

However we have found this is NOT a CBA bug.

This was reproduced by a member of our CBA Team:
"I can actually reproduce this. Without having CBA loaded, or any other mods for that matter..."
http://forums.bistudio.com/showthread.php?147535-CBA-Community-Base-Addons-ARMA-3-Alpha&p=2686035&viewfull=1#post2686035

May 10 2016, 8:17 AM · Arma 3
ViperMaul added a comment to T76790: AMV-7 Marshall 40mm canon damage issue (edit CBA related).

Tested

A3 Stable - No Mods: Unable to Reproduce
A3 Stable - CBA: Unable to Reproduce
A3 Stable - CBA + JSRS v2.1: Unable to Reproduce
A3 Stable - CBA + SpeedOfSoundv2: Reproducible

Other Notes:
With SpeedOfSoundV2, I also noticed no explosions on impact like you see in A3 - No Mods

The issues appears to be sourced in the SpeedOfSoundv2 mod.
However, the mod does sound good.

May 10 2016, 8:09 AM · Arma 3
ViperMaul updated subscribers of T73657: addUniform is NOT Global.

@KillZone,
I thought about contacting you before this bug report.
Our test results only differs with the backpacks, aside from the fact, that I didn't test the googles.
Actually your test results make more sense when I work with my addon.

How did you do your tests?

Here is what I did...

All on the same box,
Dedicated Server + 2 Clients.
Client A used the Debug Console. Execute the commands in appropriate order.
Client B monitored the result. Client B was in his own group.

I observed the Backpack removed from the Client A player on both clients.
I observed the Backpack added to the Client A player on both clients.
I then believed the both backpack commands where Global.

Since we both used the same Dev Branch version, again I ask how did you do your tests?

May 10 2016, 6:48 AM · Arma 3
ViperMaul edited Steps To Reproduce on T73657: addUniform is NOT Global.
May 10 2016, 6:48 AM · Arma 3
ViperMaul added a comment to T73403: AI Gun shots inaudible after reload..

Excellent!

May 10 2016, 6:41 AM · Arma 3
ViperMaul added a comment to T73148: Get Fatigued By Zooming Binoculars.

Weapon sway should also be removed from Binoculars
This is possibly related to http://feedback.arma3.com/view.php?id=12559

May 10 2016, 6:30 AM · Arma 3
ViperMaul added a comment to T72935: Missing of scripting commands for inventory.

The following do not seem to work with cfgMagazines.

  • unit addItemToUniform item
  • unit addItemToVest item
  • unit addItemToBackpack item

Example:
Using the Debug console on a dedicated server scenario, the following fails
player addItemToBackpack "HandGrenade"

Gives the following RPT error summary:
Warning Message: No entry 'bin\config.bin/CfgWeapons.HandGrenade'.
Warning Message: Error: creating weapon HandGrenade with scope=private

Entire RPT error: http://pastebin.com/B26DQh6Z

Same error happens with the following command
player addItemToBackpack "SmokeShell"

May 10 2016, 6:25 AM · Arma 3
ViperMaul added a comment to T72078: nearestBuilding crashes the game with Altis.

Confirmed fixed for me on 03.110218 dev branch using ceeeb's repo steps.

May 10 2016, 6:03 AM · Arma 3
ViperMaul added a comment to T72078: nearestBuilding crashes the game with Altis.

I ran into this problem today during development as well.
No problems testing on Stratis.
Also Nou reports "nearEntities is fairly quick"

May 10 2016, 6:03 AM · Arma 3
ViperMaul added a comment to T71143: Multiplayer crashes "steam ticket check failed: [null]".

Dwarden, expect crashlogs in your email within the next 24 hours.
We had at least 6 people crash tonight and I have screenshots of at least 4 got the steam ticket check failed message.

May 10 2016, 5:37 AM · Arma 3
ViperMaul added a comment to T71143: Multiplayer crashes "steam ticket check failed: [null]".

Additional Note:

  • We were using the DEV Branch(0.77.109561) on August 28th. (66+ players)
  • VON was disabled as we use ACRE.
  • It happened again using DEV Branch (0.77.109586) on August 31st.(59+ players)
  • This second night it only happened to other friends. Not me.

I sent my crash logs directly to Dwarden via email as did many of my friends. However, I cannot be sure if all the client crashes were related to this bug or not.

Dwarden you can reference the following crashlogs I sent you in email on that day after.

  • arma3_2013-08-28_16-56-17.mdmp
  • arma3_2013-08-28_18-49-11.mdmp
  • arma3_2013-08-28_16-54-11.mdmp

However, I don't think these crash logs were specific to this bug. But who knows.

May 10 2016, 5:37 AM · Arma 3
ViperMaul added a comment to T71143: Multiplayer crashes "steam ticket check failed: [null]".

I have seen this once personally.
But many times with friends. It was in a recent DEV branch before the official release. It appears that some people may be receiving this in the official release now.

On going discussion-
http://forums.bistudio.com/showthread.php?154590-Player-x-kicked-off-Steam-ticket-check-failed-%28null%29&p=2508654&viewfull=1#post2508654

Other bug references:
http://feedback.arma3.com/view.php?id=7039#c20067
http://feedback.arma3.com/view.php?id=7057
http://feedback.arma3.com/view.php?id=8279
http://feedback.arma3.com/view.php?id=13539

May 10 2016, 5:37 AM · Arma 3
ViperMaul added a comment to T70883: Many BIS Missions on a Dedicated server fails to reach the slot selection screen (Dev Branch).

Ah you guys beat me to it. :) I blame it on living in the west.
Yes. I can no longer reproduce the problem with the dedicated server.
Good job dazhbog!

May 10 2016, 5:28 AM · Arma 3
ViperMaul edited Steps To Reproduce on T70883: Many BIS Missions on a Dedicated server fails to reach the slot selection screen (Dev Branch).
May 10 2016, 5:28 AM · Arma 3
ViperMaul added a comment to T70650: removeUniform command does not work in multiplayer (server).

I hear this should be fixed now? Can anyone confirm?

May 10 2016, 5:20 AM · Arma 3
ViperMaul edited Steps To Reproduce on T70453: Undefined variable in expression: _colorpreset, A3\functions_f\GUI\fn_displayColorGet.sqf, line 63.
May 10 2016, 5:13 AM · Arma 3
ViperMaul edited Steps To Reproduce on T70452: Error Undefined variable in expression: _placeableaddons, A3\functions_f\Curator\fn_curatorAddPlaceableAddons.sqf.
May 10 2016, 5:13 AM · Arma 3
ViperMaul edited Steps To Reproduce on T70451: Error Zero divisor - File A3\functions_f\arrays\fn_arrayShift.sqf, line 30.
May 10 2016, 5:13 AM · Arma 3
ViperMaul added a comment to T69681: Error Undefined variable in expression: _params: A3\functions_f\Debug\fn_param.sqf, line 44.

I haven't seen this one in a while.
I'm at work. Can someone confirm it is fixed?

May 10 2016, 4:44 AM · Arma 3
ViperMaul added a comment to T69681: Error Undefined variable in expression: _params: A3\functions_f\Debug\fn_param.sqf, line 44.

Seems to be fixed in Version: 0.73.107682 (Dev)

May 10 2016, 4:44 AM · Arma 3
ViperMaul added a comment to T69681: Error Undefined variable in expression: _params: A3\functions_f\Debug\fn_param.sqf, line 44.

Apologies... I didn't see this post in my morning read. I only saw and read the Sitrep.

This is a known issue as I thought it might be anyway.
This post came sometime after my morning read
http://forums.bistudio.com/showthread.php?149636-Beta-Development-branch-changelog&p=2437931#post2437931

May 10 2016, 4:44 AM · Arma 3
ViperMaul added a comment to T69681: Error Undefined variable in expression: _params: A3\functions_f\Debug\fn_param.sqf, line 44.

It looks like it could make use of a nil check?
http://pastie.org/private/ynjpkchjo90xkvsy25joa#42

May 10 2016, 4:44 AM · Arma 3
ViperMaul edited Steps To Reproduce on T69681: Error Undefined variable in expression: _params: A3\functions_f\Debug\fn_param.sqf, line 44.
May 10 2016, 4:44 AM · Arma 3
ViperMaul added a comment to T68216: Some of magazines weren't stored in soldier Vest or Uniform? - Soldier are having too much equipment.

Ah I thought this was due to my mod.
Yep. I am getting this also in Version: 0.73.107682 (Dev)

I just started with no mods and no extra command-line params.
And watched the demo mission fight on the first main screen.

The following showed up in the RPT
soldier[O_Soldier_AR_F]:Some of magazines weren't stored in soldier Vest or Uniform?
soldier[O_Soldier_AR_F]:Some of magazines weren't stored in soldier Vest or Uniform?
soldier[O_Soldier_AR_F]:Some of magazines weren't stored in soldier Vest or Uniform?

May 10 2016, 3:46 AM · Arma 3
ViperMaul added a comment to T67300: Reloading weapon / placing explosive / switching firemode is audible far away from source.

Yeah I just confirmed testing 1.26 Stable and all of the above are fixed in-game. However, if you are running spectator and you zoom out and the player that your camera is attached to fires, the sounds closures speed of sound is wrong, it is instant, it is more like speed of light. It kind of ruins video recording.

I recorded these issues on 1.22 and 1.26. I will post them later.

But I am so pleased that the most significant parts of this is fixed.

Note 1:
For me I noticed that the satchel charge arming sound was quieter in dedicated server mode vs slightly louder in self-hosted mode in two-human player tests. But both were satisfactory levels I think.

Semi-related note 2: The current HLC and RH rifles has their changeFiremodeSound too loud. They should be lowered to match the distance now set by the 1.26 default BI weapons like the MX. My opinion is subjective of course.

May 10 2016, 3:14 AM · Arma 3
ViperMaul added a comment to T65073: !alive check for multiple playable units does not work when slot not filled.

Interesting.
You should probably attach an easy repro mission that would help for a quick fix by the developers.

How does https://community.bistudio.com/wiki/lifeState work in your situation?

May 10 2016, 1:47 AM · Arma 3
ViperMaul added a comment to T64687: Cannot load sound 'a3\dubbing_radio_f\data\male01\radioprotocoleng\normal\misc\movetogrid.ogg'.

Confirmed Fixed.

May 10 2016, 1:33 AM · Arma 3
ViperMaul added a comment to T64687: Cannot load sound 'a3\dubbing_radio_f\data\male01\radioprotocoleng\normal\misc\movetogrid.ogg'.

Still present in latest..

Exe timestamp: 2013/04/15 06:43:00
Current time: 2013/04/15 06:45:32

Type: Public Alpha
Branch: Stable
Version: 0.54.103957

May 10 2016, 1:33 AM · Arma 3
ViperMaul edited Steps To Reproduce on T64687: Cannot load sound 'a3\dubbing_radio_f\data\male01\radioprotocoleng\normal\misc\movetogrid.ogg'.
May 10 2016, 1:33 AM · Arma 3
ViperMaul added a comment to T63848: Error in expression: Error Missing ; A3\modules_f\sites\procedures\selectUnitCiv.sqf, line 30.

After updating to the Dev Branch I get the same error.

Additional Info:
addons\modules_f.pbo - 44664
addons\modules_f_data.pbo - 40648

I will upload the RPT file.

May 10 2016, 1:00 AM · Arma 3
ViperMaul added a comment to T63848: Error in expression: Error Missing ; A3\modules_f\sites\procedures\selectUnitCiv.sqf, line 30.

Good Job! I no longer see the error message!

"C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe" -skipinto -world=empty -nosplash -showScriptErrors -noFilePatching

Exe timestamp: 2013/03/28 03:37:32
Current time: 2013/03/28 07:05:11

Type: Public Alpha
Branch: Development

Version: 0.53.103558

C:\Program Files (x86)\Steam\steamapps\common\Arma 3\addons\modules_f.pbo - 44757
C:\Program Files (x86)\Steam\steamapps\common\Arma 3\addons\modules_f_data.pbo - 40648

May 10 2016, 1:00 AM · Arma 3
ViperMaul edited Steps To Reproduce on T63848: Error in expression: Error Missing ; A3\modules_f\sites\procedures\selectUnitCiv.sqf, line 30.
May 10 2016, 1:00 AM · Arma 3
ViperMaul added a comment to T63847: RPT SPAM: Cannot load sound 'a3\sounds_f\characters\footsteps\dirt_walk_new_8.wav'.

It is the same.
The latest Dev release has fixed this issue.

Type: Public Alpha
Branch: Development
Version: 0.53.103342

You may close as duplicate of #4943

May 10 2016, 1:00 AM · Arma 3
ViperMaul added a comment to T63847: RPT SPAM: Cannot load sound 'a3\sounds_f\characters\footsteps\dirt_walk_new_8.wav'.

Thanks Fireball

May 10 2016, 1:00 AM · Arma 3
ViperMaul edited Steps To Reproduce on T63847: RPT SPAM: Cannot load sound 'a3\sounds_f\characters\footsteps\dirt_walk_new_8.wav'.
May 10 2016, 1:00 AM · Arma 3
ViperMaul added a comment to T63020: Feedback Tracker error 1100.

I got this today as well.
I also notice the upload button is mission when creating a new issue.

Workaround:
Make sure the upload file path is untouched.
Upload the file after you create the bug report.

May 10 2016, 12:27 AM · Arma 3
ViperMaul added a comment to T63007: RPT Error on Startup: fn_syncUAV.sqf, line 34 - Error Missing ;.

Confirmed Fixed.

May 10 2016, 12:26 AM · Arma 3
ViperMaul edited Steps To Reproduce on T63007: RPT Error on Startup: fn_syncUAV.sqf, line 34 - Error Missing ;.
May 10 2016, 12:26 AM · Arma 3
ViperMaul added a comment to T63006: RPT Error on Startup: fn_guiMenuUAV.sqf, line 13 - Error Missing ;.

As a result of the most recent DEV branch update
"UAV module(s) temporarily removed / disabled for heavy maintenance."

Type: Public Alpha
Branch: Development
Version: 0.51.103185

This error is no longer showing up in the RPT file.

May 10 2016, 12:26 AM · Arma 3
ViperMaul added a comment to T63006: RPT Error on Startup: fn_guiMenuUAV.sqf, line 13 - Error Missing ;.

This was related to http://feedback.arma3.com/view.php?id=4640

May 10 2016, 12:26 AM · Arma 3
ViperMaul edited Steps To Reproduce on T63006: RPT Error on Startup: fn_guiMenuUAV.sqf, line 13 - Error Missing ;.
May 10 2016, 12:26 AM · Arma 3
ViperMaul added a comment to T63005: RPT Error on Startup: fn_guiEventsUAV.sqf, line 31 Error Missing ).

This was related to http://feedback.arma3.com/view.php?id=4640

May 10 2016, 12:26 AM · Arma 3
ViperMaul added a comment to T63005: RPT Error on Startup: fn_guiEventsUAV.sqf, line 31 Error Missing ).

As a result of the most recent DEV branch update
"UAV module(s) temporarily removed / disabled for heavy maintenance."

Type: Public Alpha
Branch: Development
Version: 0.51.103185

This error is no longer showing up in the RPT file.

May 10 2016, 12:26 AM · Arma 3
ViperMaul added a comment to T63005: RPT Error on Startup: fn_guiEventsUAV.sqf, line 31 Error Missing ).

Attached RPT

May 10 2016, 12:26 AM · Arma 3
ViperMaul edited Steps To Reproduce on T63005: RPT Error on Startup: fn_guiEventsUAV.sqf, line 31 Error Missing ).
May 10 2016, 12:26 AM · Arma 3

May 9 2016

ViperMaul added a comment to T59900: Some controls still active while chatting.

This is still an very significant issue in the current dev and stable builds. With the grenade keybinds it can be lethal to your nearby teammates. Accidental death can happen. Especially when you rebind your grenade key to say 2xT and you type the word Attack. I am glad to see this issue is assigned and set to urgent already.

May 9 2016, 7:18 PM · Arma 3