RictorScale
User

Projects

User does not belong to any projects.
User Since
Jun 13 2015, 5:26 AM (131 w, 5 h)

Recent Activity

Jun 17 2017

RictorScale added a comment to T80668: setObjectTextureGlobal causing "Cannot load texture" errors when used with valid mission files.

I confirm this is still happening. In my case it is affecting custom insignias. On the server it works fine for host player and any AI team members. That is, it gives no error and insignias look great in-game. However, clients connecting (via Steamworkshop) receive this error "Cannot load texture steammpmission\__CUR_MP.Altis".

Jun 17 2017, 8:27 PM · Arma 3

Dec 24 2016

RictorScale added a comment to T83906: Enemy troops spawned with 'createUnit' command will not fire on airborne enemy aircraft..

This still appears to be broken. With the release of Tanoa I've noticed it happens only to the alternate factions for a side. For Tanoa for example, if you spawn via script any Tanoa variant of a CSAT unit such as "O_T_Soldier_SL_F" (to an 'east' side group of course) they will not fire on a 'west' side chopper even if it's hovering a foot over their head. If you touch a wheel to the ground they open fire, raise a foot again and they stop firing.

Dec 24 2016, 2:56 AM · Arma 3

May 10 2016

RictorScale added a comment to T83906: Enemy troops spawned with 'createUnit' command will not fire on airborne enemy aircraft..

If desired I can make a simple mission and attach the troop spawn to a radio command.

May 10 2016, 11:52 AM · Arma 3
RictorScale edited Steps To Reproduce on T83906: Enemy troops spawned with 'createUnit' command will not fire on airborne enemy aircraft..
May 10 2016, 11:52 AM · Arma 3
RictorScale added a comment to T83906: Enemy troops spawned with 'createUnit' command will not fire on airborne enemy aircraft..

After much more testing with east forces, oddly enough this bug/issue is specific to the 'guerilla' style of east units prefixed with "O_G_" such as "O_G_Soldier_F", "O_G_Soldier_lite_F", "O_G_Soldier_SL_F", etc. This is with the exception of the AR gunner, "O_G_Soldier_AR_F", which works okay. Other 'standard' east units like "O_Soldier_F" and "O_Soldier_AA_F" work fine too.

I am unsure how to place these kinds of 'east guerilla style' units with the editor so I couldn't compare that method. My attached PBO adds the problem units via script.

May 10 2016, 11:52 AM · Arma 3
RictorScale added a comment to T83906: Enemy troops spawned with 'createUnit' command will not fire on airborne enemy aircraft..

I added a simple mission PBO file to easily create this issue.

May 10 2016, 11:52 AM · Arma 3
RictorScale added a comment to T82869: Scripted radio messages are spoken locally - breaks all voice acting..

This is definitely a duplicate of #0024437 and possibly #0024419. I have more details and re-creation steps in the former.

May 10 2016, 11:18 AM · Arma 3
RictorScale added a comment to T82804: No sound on reports in helicopter support missions.

I can confirm this issue. It seems to be part of larger bug introduced with radio commands (sideRadio, customRadio, etc.) The simplest description is the audio (ogg) portion of these commands appears to now be acting with positional effect. So if you execute a radio command (in a script or console) it will play full, normal volume if the source is adjacent to the listener but fades out completely over ~500m. As 'Akibuua-FIN-' reports, a listener will see the text properly along with the the final beep, but if the source is over 500m no sound will be heard. RECREATION STEPS: Pretty easy. Create a mission, place two soldiers on the same side, copy in any working ogg file from another mission, set up your CfgRadio like normal in the description.ext. Preview the mission, as player1 execute the sideRadio command varying player1 and player2 as the source (e.g. player1 sideRadio 'radio1'; & player2 sideRadio 'radio1';), then slowly have player2 move out a 100m at a time. (I've confirmed this in my own missions both with sideRadio and customRadio and in preview mode, MP, ded server.) I'm not running any mods for this test.

May 10 2016, 11:16 AM · Arma 3
RictorScale added a comment to T82804: No sound on reports in helicopter support missions.

I believe this is a duplicate of (or at least overlaps with) open issue #0024419.

May 10 2016, 11:16 AM · Arma 3
RictorScale added a comment to T82786: [RC] AI voice chat is broken.

Based on H's first note above, I believe this is the same problem as issue #0024437. That is, the missing 'audio' portion of a radio message ... both in campaigns as well as missions with sideRadio, customRadio, etc. In that ticket I've posted more details and re-creation steps.

May 10 2016, 11:15 AM · Arma 3
RictorScale added a comment to T76644: Maximum achievable horizontal speed during freefall way too low.

This appears to still be waiting for a permanent fix. However, I've noticed it's temporarily fixed when initiating a jump with BIS_fnc_halo which increases the ground 'tracking' speed to 220 km/h.

The documentation on this function is a little light, but this works for me: '[_unit, _altitude] call BIS_fnc_halo'. It needs to be run locally.

May 10 2016, 8:05 AM · Arma 3