Page MenuHomeFeedback Tracker

[RC] AI voice chat is broken
Closed, ResolvedPublic

Description

EDIT: In dev/RC branch only, AI now take long pauses in between each phrase in non-radio chat.

Details

Legacy ID
751938506
Severity
None
Resolution
Reopened
Reproducibility
Always
Category
AI Issues
Steps To Reproduce
  1. Have yourself move into battle with a lot of friendly AI squads
  2. Listen to their broken dialogue

Event Timeline

SomeSangheili set Category to AI Issues.
SomeSangheili set Reproducibility to Always.
SomeSangheili set Severity to None.
SomeSangheili set Resolution to Reopened.
SomeSangheili set Legacy ID to 751938506.May 8 2016, 12:13 PM
SomeSangheili edited a custom field.
h- added a subscriber: h-.May 8 2016, 12:13 PM
h- added a comment.Jun 13 2015, 7:45 PM

This problem actually seems to affect all squad radio?

Because if I order AI dudes around, for example order regroup for 2, all I hear is "2" and then about a ten second silence after which the 'radio close' sound is heard (the radio text shows the whole sentence).
The AI never replies.
It does however do what the now telepathic command tells it to.

This also affects the command queue with making it very slow..

^ Have not encountered that, but will edit OP if I do

h- added a comment.Jun 14 2015, 7:14 AM

I'm on DevBranch, have verified game cache and all that jazz and this has been going on for me since like last Thursday or something.. :(

As well, I've noticed that KBTell conversations are acting a little odd - lip sync seems to stop, randomly. Really hard to reproduce, as it does not happen every time.

Based on H's first note above, I believe this is the same problem as issue #0024437. That is, the missing 'audio' portion of a radio message ... both in campaigns as well as missions with sideRadio, customRadio, etc. In that ticket I've posted more details and re-creation steps.

R34P3R added a subscriber: R34P3R.May 8 2016, 12:13 PM

BIS releasing new terrain but not fixing major bugs. Slowly I lose the desire to play this game or building missions for it.

Adam added a comment.Jun 23 2015, 1:00 PM

Will be fixed in tomorrows devbuild!

Thanks for that, Adam! :) Good to hear!

WAS NOT FIXED
On Dev Build 1.47.131311, this issue (http://feedback.arma3.com/view.php?id=24502) is still present. Check the attachment for easy testing.

Adam added a comment.Jun 25 2015, 10:46 AM

Just tried reproducing it on Dev Build 1.47.131311. I can hear every radio message correctly without any issue.

Adam: do you mean you tried the sideRadio test mission? You don't have any issue?
If that's the case I'll record a video.

Adam added a comment.Jun 25 2015, 12:44 PM

I was able to reproduce the issue thanks to your well made Repro Mission. The issue has been scheduled for a fix.

iS this normal that there is no Voice by AI-Commanding without Radio equiped ?

Adam added a comment.Sep 7 2015, 12:54 PM

Fixed again on devbranch.

This bug is fixed

h- added a comment.Oct 24 2015, 6:44 PM

And now, not fixed again.. :P
In Dev, obviously.

(tested in SP) this extends to more than AI like once before, anyone reporting a target will say normally via radio 'Contact' after which radio goes dead, then in off-radio you can hear the unit say for example 'sniper' (or whatever the unit/player is reporting) but the distances and the like (like multiple targets: 'sniper AND medic') are left out and a stream of 'Missing word blah blah XMIT' errors are logged in the rpt..

Really close to what was happening when this bug was being reported when I last commented on this ticket..

Fixed in 1.54 (tested in RC build)

Koala added a subscriber: Koala.May 8 2016, 12:13 PM

According to the author the issue seems to be resolved

It's broken again on dev branch without radios. AI now take long pauses in between each word. eg. "contact...rifleman...100 metres...north."

Koala added a comment.Feb 1 2016, 1:30 PM

@SomeSangheili

Feel free to re-open your ticket with a feedback.

It says access denied when I try :\

Koala added a comment.Feb 1 2016, 6:08 PM

Re-opened

dedmen closed this task as Resolved.Tue, Jul 21, 12:07 PM