Scripted radio messages are spoken locally - breaks all voice acting.
Assigned, WishlistPublic

Description

When using groupRadio, sideRadio, globalRadio, I use actors that are far from the battlefield so that I can control better the flow.
I noticed that I can't hear the messages even though the sound files are properly recorded and declared in the description.ext.

In a nutshell: the text is broadcasted correctly to the right channel but the audio is spoken locally, as if on directSay. You can hear the radio squawk but if you're too far away you will not hear the message.

NOTE: also kinda breaks vehicleRadio, it'll be muffled. {F26473}

Details

Legacy ID
2748983604
Severity
None
Resolution
Duplicate
Reproducibility
Always
Category
Sound
Steps To Reproduce

I have made a test mission that shows the issue: see attached file. Just put it in your /Missions folder and play it as a SP scenario. Issue is also present in MP.

Otherwise, easy enough to reproduce. Just put a voice actor on the other part of the map, give him a .ogg to say, make him say it. You won't hear it.

SPhoenix edited Steps To Reproduce. (Show Details)Jun 19 2015, 4:44 PM
SPhoenix set Category to Sound.
SPhoenix set Reproducibility to Always.
SPhoenix set Severity to None.
SPhoenix set Resolution to Duplicate.
SPhoenix set Legacy ID to 2748983604.May 8 2016, 12:15 PM
SPhoenix edited a custom field.

This is definitely a duplicate of #0024437 and possibly #0024419. I have more details and re-creation steps in the former.

You are absolutely correct. Thing is, this is quite critical. It breaks voice acting.

Adam added a comment.Jun 30 2015, 10:52 AM

Did this issue surface with the 1,46 patch or was it present long before that?

I believe this emerged with 1.46, I've been using voice acting a lot lately and only noticed the bug recently.

Adam added a comment.Jun 30 2015, 11:14 AM

Ok. Thank you very much!

Adam added a comment.Jul 3 2015, 8:25 AM

Fixed in dev branch!

Add Comment