Page MenuHomeFeedback Tracker

bad_module_info
New, NormalPublic

Description

Game randomly crashes with this as my error popup screen.

Details

Severity
Crash
Resolution
Open
Reproducibility
Random
Operating System
Windows 10 x64
Operating System Version
1709
Category
Game Crash
Steps To Reproduce

Have not been able to reproduce with any success. Has occurred while driving, walking, standing still in inventory, standing still doing nothing, in and out of combat. Time to happen varies as well. It has happened within the first minute or so of loading into the game, and after an hour or more. Tried changing Windows compatibility modes, and also turned off full screen optimizations within Windows.

Additional Information

Related Objects

StatusAssignedTask
NewNone
Need More InfoNone

Event Timeline

kev2tall created this task.Nov 29 2017, 8:00 PM
Wulf added a subscriber: Wulf.Nov 30 2017, 11:41 AM

Hello.

Thank you for the report. I see that you some mods enabled does the crash occur even with mods disabled?

I've been getting this crash and error mutliple times while playing one of the new Tac-Ops missions for the DLC. I haven't been running any mods other than some Steam Workshop community produced scenarios (which shouldn't have any effect on playing a BI produced scenario). I've got an error report saved if you need it.

Wulf added a comment.Dec 4 2017, 9:17 AM

Ok, could you please tell me exactly during which Tac-Ops mission it occurs and when exactly it occurs? I want to try and recreate the issue.

Thank you.

Wulf changed the status of subtask T127248: Game crash with bad_module_info error from New to Need More Info.Dec 4 2017, 1:15 PM

I have not had the error since I posted this. I later that day switched to playing Fullscreen Windowed from Fullscreen and it seems to have stopped it for now. The only thing I can say going forward Wulf, is that based on this issue showing up for other games (PUBG, CS:GO, Paladins these were the games on the first Google search for bad module_info) it's looking more like a Windows issue, not with Arma.

Wulf added a comment.Dec 5 2017, 10:09 AM

Thank you for letting us know. Indeed the latest update from windows screwed some games. If it is happening in other games then it is highly probable that the OS is screwed.

It happens to all of my testers so i can´t test anything.
Also object builder camera is screwed.

I've gotten this error many times since the recent Windows update. I'm on the Dev branch of the game with several mods loaded, but there's one mod in particular that I can recreate the error with without fail, Personal Arsenal. My friend has the same mod, playing on the same server, doing the same thing, but his never does it. I get the error mostly when closing PA but I have gotten it while entering it. I've gotten "bad_module_info" a few times leaving the map but it does not appear as often as the PA crash. It crashes both in singleplayer and multiplayer.

Wulf added a comment.Dec 14 2017, 9:49 AM

We are currently working on a fix regarding the bad_module_info error. Hopefully it will solve most of the bad_module errors.

So hang in there.