Page MenuHomeFeedback Tracker

Object Builder viewports acting erratically with Windows 10 Fall Creators Update
Reviewed, NormalPublic

Description

Microsoft is slowly rolling out the Fall Creators Update to Windows 10 users.

This update has a side-effect in OB of the viewports acting slow/sluggish and sometimes erratic in non-directx mode.

It's pretty hard to articulate the issue in words, so I created a video demonstrating the unwelcome effects of the Win10 FCU and that this issue would need to be investigated along with a compatibility update to Object Builder pushed out for Windows 10 users.

https://youtu.be/Z4xutwnaTeI

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Operating System Version
Version 1709 (OS Build 16299.64)
Category
Tools
Steps To Reproduce

Use Windows 10 as your operating system.
Have the 'Fall Creators Update' installed.
Load OB.
Load any model.
Try and rotate your viewports without directx mode enabled.
Rejoice at Redmond.

Additional Information

See video linked above for visual evidence of this issue.

Event Timeline

Uro created this task.Nov 20 2017, 11:25 PM
Uro renamed this task from Object Builder viewports acteing erratically with Windows 10 Fall Creators Update to Object Builder viewports acting erratically with Windows 10 Fall Creators Update.Dec 3 2017, 12:16 AM
Sentado added a subscriber: Sentado.Dec 5 2017, 7:19 PM

Same problem , this has to be solved as soon as possible. It is really hard/impossible to editing or modeling in Object Builder. Tried several times to unnistall and nothing works.
Here you can see my issue:
https://i.gyazo.com/94d14c10acbac909dc39b09ce5fcb34f.mp4

Pierre added a subscriber: Pierre.Dec 17 2017, 12:58 PM

Same problem

Wulf changed the task status from New to Reviewed.Dec 18 2017, 5:36 PM
Wulf added a subscriber: Wulf.

Hello.

We are aware of the problem that the last update of Windows caused we are in the process of fixing them.

dedmen added a subscriber: dedmen.Dec 30 2017, 7:54 PM

I'm on Win 8 with automatic updates disabled and the problem appeared without windows updates in between.

What is the progress of the update for object builder following the update fall creators update? we can not work anymore, I hope it will be settled at the quickest

Wulf added a comment.Jan 8 2018, 1:47 PM

For now, no new info I am afraid. We are working on it and looking for other issues that the update caused along the way so I ask of you for a little bit of patience. Thank you.

What is the progress of the update ?

this needs to be fixed ASAP, object builder is unusable like this, whether its BI or MS fault

Are there any further updates to this issue? Can confirm it only happens on Fall Creators Update for me, I've kept rolling back windows 10 but it force updates every week so it gets old after a while.

skyllio added a subscriber: skyllio.EditedMar 27 2018, 4:27 PM

I have the same bug since November as well. But mine almost works normal if the vertex count is below 1000. It then get worse as the vert count gets higher, anything above 10 000 verts is pretty much unusable unless i turn on Direct3d.

encounter this problem since yesterday too. Also my textures wont load anymore in buldozer. Hope this get fixed soon

Uro added a comment.Apr 27 2018, 4:11 PM

@Wulf any updates on this issue? It has been in the wild for some 6 months now.

@Uro on windows 8.1 I'm not worried anymore

Uro added a comment.May 2 2018, 4:09 PM

You are unfortunately missing the point.
Changing operating system to get around an issue does not actually fix the issue.

I'll await an update on here from BI regarding this issue.

dedmen added a comment.May 2 2018, 6:53 PM

Still experiencing the bug on Windows 8.1

This problem still persists. Switching to Direct3D helps some, but any mouse operation still seems to be broken.

Hello
someone found how to fix the worry?

I am in the stable version of windows 10 and the worry persists?

Hello,
This problem still persists.
I am in Windows 10 stable version.
Any fix plz ?
thx

Also having that issue - Is there any known workaround?

BI Team .. it would be great if someone could pick this up at last. There is no known workaround besides switching OS atm.!! And this is really annoying ...

This comment was removed by Geez.
Geez added a subscriber: Geez.Oct 23 2018, 10:34 AM
Coyte added a subscriber: Coyte.Sat, Mar 16, 1:45 PM