Page MenuHomeFeedback Tracker

Sounds / music randomly lost or stopped with game saves (More info given)
Assigned, WishlistPublic

Description

Since the latest update, sounds and music sometimes (not always!) stop when a game is saved. (Video added)

Details

Legacy ID
3624039263
Severity
None
Resolution
Open
Reproducibility
Random
Category
Sound
Additional Information

Event Timeline

Bohemia edited Additional Information. (Show Details)Jun 14 2015, 9:58 PM
Bohemia set Category to Sound.
Bohemia set Reproducibility to Random.
Bohemia set Severity to None.
Bohemia set Resolution to Open.
Bohemia set Legacy ID to 3624039263.May 8 2016, 12:14 PM
Bohemia edited a custom field.
R3vo added a subscriber: R3vo.May 8 2016, 12:14 PM
R3vo added a comment.Jun 15 2015, 10:55 AM

Upvoted, happens very rarely.

As R3VO states, it IS happening but not always often.

Happens every time for me, at certain saves!

Adam added a comment.Jun 16 2015, 12:03 PM

Hello, unfortunately i was not able to reproduce the issue. Could you please provide more info? Thank you.

Unfortunately, for many of us, it seems to be happening at random (and hard to reproduce). Perhaps I could upload a video? Let me know if there's anything more helpful I can provide.

I'll try and get a video together.

@Adam - here we go! https://www.dropbox.com/s/h50blqjp6rspik2/Music%20Issue.avi?dl=0

In the video you can hear the music - then, once the player reaches the autosave point, it saves, music stops, and does not return.

I think a few people are experiencing this at the moment. Can't replicate every time though.

I've noticed it occurring in the main campaign too, but randomly. I'm not sure if it's related, but where I seem to be able to replicate the issue consistently the unitPlay function is active. Sounds rooted in the config and playing from the createSoundSource command are not effected. I've added the video, just let me know if there's anything else I can provide. It's occurring on Dev Branch and Stable at present.

I remember it since OFP, it game engine releated. If there is scripted music sections, entering to menu via [ESC] key, or saving (you must press [ESC] to save) is resoulting skiping to next music section. For example if music is cuted for 4 parts and is playing, and we go to manu, and back in game, sound ebgine is jumping to next part, after this one, before we entered menu.

Now, with the autosave command (saveGame), when the sound is temporarily stopped during the saving process, the music doesn't always return.

R_Marx added a subscriber: R_Marx.May 8 2016, 12:14 PM

Confirmed +1. Politely suggest this should be assigned :-)

For me music is cutting after ~10 seconds without a reason

Cheers for assigning, Adam - many thanks :)

Just to confirm, issue is still present on the updated Stable branch.

It happens on 1.48 - confirmed

This problem is really a pain. I cant use music with game saving.

Music still not working. Have it happening in main campaign?

Yeah, can confirm :)

Can also confirm this problem is happening on campaign, as well as custom missions. Haven't tried on dev branch for a while. Is anyone experiencing this when not saving a game? So far, I've found, the music only stops with the savegame command.

bug persist on dev. annoying as hell.

Yeah, just tried on Dev.

scft added a subscriber: scft.May 8 2016, 12:14 PM
scft added a comment.Aug 20 2015, 7:27 AM

This does break certain scenarios where the voice is dubbed. Pausing game also causes music to restart.

Adam added a comment.Aug 20 2015, 10:47 AM

I'm able to reproduce the issue on RC quite frequently but not on DEV. Can you take a look please?

Adam added a comment.Aug 20 2015, 12:17 PM

We have managed to reproduce the issue and the issue is scheduled for a fix.

Great news, Adam! Thanks for looking into that :)

Adam is the man!

Adam added a comment.Aug 21 2015, 10:06 AM

Little bit of a info: It seems to be only present for certain conversations and does not apply to every conversation / music. Also thank you for your kind words!

Please fix this bug.

Still awaiting a fix on this - playMusic is pretty much broken at the moment.

Looks like the bug persists on stable, don't know about Dev. Haven't seen anything in changelog about it yet. But no doubt it's being working on.

Tested on Dev this morning, and can confirm the issue persists.

Nitro added a subscriber: Nitro.May 8 2016, 12:14 PM
Nitro added a comment.Sep 24 2015, 9:43 AM

I am also having this trouble. Please fix as I cannot make my music loop because save game stops it.

Music is not working for me. It repeats and stops when it is not supposed to. I press escape with sound and music repeating.

Not working in 1.52

ahhh bohemia.....

+1. Sound and music are buggy still

This is a PITA. Destroys a lot of atmosphere...
Please fix it soon, BIS. Thanks.

1.53 beta

i can bump the most important tickets but what for - they are just ignoring it.....

IMO this is pretty urgent. Music stops even when my computer has to process something. Even on the main menu. Music is cutting out way too often leaving missions silent.

This is also happening on the main menu screen.

Nitro added a comment.Oct 8 2015, 9:47 AM

at the mo I am forced between allowing saves and playing music in my missions. And sounds / music are repeating too!

Any news? This was assigned some months ago and it is a pretty nasty issue. many missions now have no music in them. As others have already commented sounds / music are repeating too.

Edit: just read Adam's note. glad it is scheduled for fix.

TutSi added a subscriber: TutSi.May 8 2016, 12:14 PM

Confirmed, when i push esc (go to pause menu) it skip song part, is i save the game, it disable music to zero.

Daishi added a subscriber: Daishi.May 8 2016, 12:14 PM

Could this be related to my issue? http://feedback.arma3.com/view.php?id=26188 This doesn't only happen to me when games are saved but also when I build different playsound, say, say3d commands in the editor. I'm under the impression that sound gets more often cut off when there are multiple sound sources using the same command at the same time. e.x.: AI soldiers calling out a lot of hostiles+costum sound commands like "this playsound "briefing";"

Nitro added a comment.Oct 17 2015, 1:47 PM

been broken for months now? Losing music every time I play.

played lots of missions on workshop and many are spoiled by this music bug. Music and sounds are repeating and getting lost.

Adam added a comment.Oct 21 2015, 10:28 AM

Will be fixed on devbranch soon™

Music still cut off for unknow reasons