Page MenuHomeFeedback Tracker

Base building items de-spawning b/c they have been there to long...
Need More Info, NormalPublic

Description

We are now having our base fences disappearing and lifetime is at 3888000, how do we act on the fence to stop it from de-spawning??????

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Category
General

Event Timeline

This really needs to be fixed!! I have people losing parts of their bases now because the lifetime must be running out..... We started having it the last couple of weeks, the fences put up when DayZ went to 1.0 are going away and you can see it following the days you did it as well.

theclassifiedrebel renamed this task from Base Fence having lifetime to Base building items de-spawning b/c they have been there to long....Apr 7 2019, 7:13 PM
theclassifiedrebel added a subscriber: Geez.

@Geez ^^^^^

Geez changed the task status from New to Need More Info.Apr 8 2019, 11:06 AM

Hello theclassifiedrebel.
Are the fences disappearing being logged in the server RPT as cleaned up or do they simply disappear without any logging message?
Regards,
Geez

I will have a look through them, but I do know that they were not damaged at all.

I do not see anything in the logs to a clean up, but not really sure what I am looking for wording wise anyway. I know it was one of the first watchtowers that was put up shortly after the 1.0 release. We have had fence disappear as well, put in one section in on the same day and that whole section is just gone and the section we put in the day after was gone the next day so it has hit some type of a clean up or despawning. I get that there should be something so people don't build all other and then leave and it is now there forever, but we need something so an admin at least knows where this is and can clean up selected bases but the bases may need a unlimited lifetime..

Geez added a comment.Jul 29 2019, 3:37 PM

Hello theclassifiedrebel.
Have you experienced this issue on any of the recent versions?
Regards,
Geez

I still am having this issue. Tents even de-spawn if not acted one for a week. I have been told by others that I need to keep planks and nails on the fences and switch them from time to time to stop it so others have the same issue by why?! 3,888,000 lifetime on it should be forever or do I need to put a 9,999,999 lifetime to stop this.....

Geez added a comment.EditedSep 5 2019, 3:49 PM

Hello again.
Did you do any modifications to the item spawning or something similar? As we had a report from a player that tents manually added into dynamic event loot (heli crashes) behaves incorrectly and despawn when they should not.
Regards,
Geez

It is the fences that are despawning, I have no way of changing anything with spawning since it is a crafted item. Other poeple have told me I have to put nails and planks on the fence even after it is fully built and move them around after a bit of time so that do not despawn. We have had this issue since the beginning and I reported it back in March. Not sure why the persistance is not working correctly because now I have to do a couple more tickets for some cars despawning and now tents and since 1.04 the Off road hatchback co-driver door despawns even while it is on the car. People losing that stuff is just unacceptable.

Had half of someones base fences gone. Can I get help on this?! It says more info needed but I have not sure what info you need or what other info I can give... nothing has been changed on the types or other files with it, I have verified files and still nothing has worked. What is “building” in globals mean? Just we get more info on server files like what was said was going to happen in the last status report. Just sick of fences being gone at log in or when I come back to base, I have tested with and without mods on 2 different drives. The odd thing is it seems to happen more to certain people and/or certain areas....

Geez added a comment.Sep 30 2019, 10:51 AM

Hello theclassifiedrebel.
We are currently investigating the issue, however, we had no such reports from other server administrators and have been unable to produce the issue on our side so far. Could this issue be related to some kind of mod?
Also, can you try to provide more details about your "What is building in globals mean" question?
Regards,
Geez

I had a gate despawn today and I even opened it a few times yesterday, it is like the timer is not being reset when I when I act on it. It is probably just other admins are not reporting it here since I see it in other discord channels as well. or like ticket "T138758" , "T134782", "T136786", "T106893" and "T109714" which is just to name a few I guess. Sorry I meant "Building" in the economy.xml file in the db folder, it does not have save or respawn as 1, all 0.... does that mean it is not saving it?? Base building items, barrels and tents should be saved like the vehicles, in their own file, but then again we have cars despawning randomly as well so maybe they should all be in the dynamic save.

I am sure if I look I can find more... I did notice if I spawn a car in it doesn't seem to have an issue, seems the ones that spawn naturally on the map are the ones with the issues as well as the off-road 4x4 seems to be the one most reported as de-spawning. The fences seem to be about the same, if materials are spawned in they last longer than ones that are built naturally.

Geez added a comment.Nov 12 2019, 12:24 PM

Hello theclassifiedrebel.
Do the issues with the vehicles occur upon a server restart? As there is a known issue that the vehicles do change position upon server restarts, which can result in the car being damaged and cleaned up. Also, some of the tickets you have linked are very dated (two created in 2015 when the game was using different engine and one in 2018 that occurred on a different version than the current one).
Regards,
Geez

Issues are random, people have left base to come back to cars gone. cars have done this since they were added back and base building items have done this since they were added into the game and I have been asking and have heard other same the same since .63 when they where both added back in with the new engine. I am not sure way you have not been able to reproduce the issue but I have heard about it and it is a known issue within the DayZ community and in every discord I go into with people talking about it and the best fix they said is to attach nails to the fence and just remove and add every couple days to stop it from going away. I had one time were a wall was there and I did that but then had to restart the server and when I did I logged into the fence being gone. No reason it should be.....

that is a 45 day thing, I have then de-spawning after someone drives the car or opens the gate even.

We are looking into a theory about how the server.cfg and the init file have different dates which cause the sun to be out of position which it may also be giving incorrect time info to the game causing the issue of the game not knowing the time you want it to be and not having a good base time to run the persistence off of.

Hello Geez,

We have a rented server and we are suffering from the same problem.

We built 2 bases.
Both of them started to disappear after few weeks, when parts started to disappear exactly in the same order as they were built.

After we did a persistence restore, we are forced since then to put any kind of building material and take it out in each module (fence, gate and tower) once a week or two, just to keep them from despawning.

The time invested in searching for materials, chopping, carrying and loading trees and planks is enormous. Such a feature, that just deletes our work should be disabled by default, if not removed.

Is there any way to change this setting in 1.06 ?

Geez added a comment.Jan 6 2020, 10:34 AM

Hello Geez,

We have a rented server and we are suffering from the same problem.

We built 2 bases.
Both of them started to disappear after few weeks, when parts started to disappear exactly in the same order as they were built.

After we did a persistence restore, we are forced since then to put any kind of building material and take it out in each module (fence, gate and tower) once a week or two, just to keep them from despawning.

The time invested in searching for materials, chopping, carrying and loading trees and planks is enormous. Such a feature, that just deletes our work should be disabled by default, if not removed.

Is there any way to change this setting in 1.06 ?

Hello,
Can you be more specific on the "few weeks"? As there is a 45 day timer.
Regards,
Geez

Hi Geez,

The fact that base buildings de-spawn after 45 days is not trivial.

After experimenting with the server for a while, I explored it's settings (xml's), I understand now that the 45 days timer can be changed.

Any object (generators, spot lights etc) or base building that already exists will still have it's old timer after this change, so only after interacting with it's materials - the new timer will take effect.

In other words - I have no issues with this now.

Thanks for the reply.

@tarkules what file and setting is that? we had no problems since doing our init/config fix for setting them to the same times but now with the new 1.07 patch we have this problem back 10 fold. would like to know what setting it is.

My tents and my barrels everything i placed down disappeared after 2 weeks i think. also a fellow survivor says hes stuff disappeared as well, everything but his car, any recommendations.