Page MenuHomeFeedback Tracker

Waypoint naming for Game Logic waypoints is wrong
Assigned, WishlistPublic

Description

Labeling/naming of waypoints for game logic is wrong.

The label in the "Select Type" field is correct, however, the label on the map and on the "Waypoint Order" field is wrong.

Details

Legacy ID
2416668302
Severity
None
Resolution
Open
Reproducibility
Always
Category
Editor
Steps To Reproduce
  1. Place a game logic
  2. Place a waypoint for the game logic.
  3. Keep the default settings ("AND") and confirm the dialog.

Expected: Hovering the mouse cursor over the waypoint should say "AND".
Observed: Hovering the mouse cursor over the waypoint says "LAND".

  1. Double click the waypoint and change its type to "OR".
  2. Confirm the dialog to close it.

Expected: Hovering the mouse cursor over the waypoint should say "OR"
Observed: Hovering the mouse cursor over the waypoint says "AND"

Additional Information

Tested with the stable build, but the bug is present since alpha (I always forgot to report it, I apologize).

Event Timeline

Alwarren edited Steps To Reproduce. (Show Details)Mar 14 2014, 1:33 AM
Alwarren edited Additional Information. (Show Details)
Alwarren set Category to Editor.
Alwarren set Reproducibility to Always.
Alwarren set Severity to None.
Alwarren set Resolution to Open.
Alwarren set Legacy ID to 2416668302.May 7 2016, 6:09 PM

Extra info: http://feedback.arma3.com/view.php?id=17829 may be related to this issue.

fixed in rev 116132

Confirmed to be working in the latest stable build. HOWEVER, the waypoints still do not work as expected, see this http://feedback.arma3.com/view.php?id=17829