Page MenuHomeFeedback Tracker

ArmA does not create a Compositions folder in my profile folder
Need More Info, NormalPublic

Description

Basically, when i try to save my own custom compositions and save them they do not save anywhere on my computer => Compositions folder doesn't exist. I've tried everything in my power and cannot get it to work in any way. (Details in Reddit thread)

This is a link to a Reddit thread where more is explained:
https://www.reddit.com/r/armadev/comments/pwi7ne/i_still_cant_save_my_own_compositions_in_any_way/

Details

Severity
Minor
Resolution
Open
Reproducibility
N/A
Operating System
Windows 10 x64
Operating System Version
God knows
Category
Editor
Steps To Reproduce

Doubt you could recreate it but still:

-Make new profile
-Try to save a composition
-Says its saved but cannot be placed down or found in the files and dissapears on editor restart

Additional Information

In Reddit link above.

Event Timeline

SrgPuffy changed Reproducibility from Unable To Reproduce to N/A.Sep 28 2021, 3:09 PM
R3vo added a subscriber: R3vo.Sep 28 2021, 10:52 PM

Can you make sure that Arma 3 has read/write access to the documents folder? I had it once that for some reason write access was removed and my saves would not be saved.

Im preatty sure it does but in case it doesnt could you tell me how to do that

dedmen changed the task status from New to Need More Info.Oct 4 2021, 10:51 AM
dedmen added a subscriber: dedmen.

Please provide the Arma RPT, it may contain error messages about why it doesn't create the compositions folder.
I need your full RPT, not the small snippet you posted on reddit.

Btw all these start parameters
-name= -high -novid -malloc=system -cpuCount=8 -exThreads=7 -malloc=tbb4malloc_bi_x64 -maxmem=16314 -maxvram=5120 -mod=
either do nothing (empty name, empty mod), plainly don't exist (high, novid), are duplicate (twice malloc?), actually hurt you (maxmem, maxvram), do nothing or hurt you (cpuCount, exThreads), potentially break your composition saving (setting -name to nothing)
You should get rid of all of these.

You also set -noLogs, which disables your RPT log. Which of course makes it useless for troubleshooting errors if its disabled.
-noLogs also doesn't provide a performance advantage anymore like it once did, so not sure why you're setting that, remove that too.

Then after removing all this recreate the problem again and send the new RPT in here

Aight cool ill do that then. To be fair i dont even remember typing most of these in.

SrgPuffy added a comment.EditedOct 4 2021, 2:25 PM

Most of the parameters are either from steam (high and novid - got rid of these, they werent supposed to be there anyway) or from the launcher settings (Ive disabled these too). But there doesnt seem to be a way to remove the mod one (i guess its made when you use mods or something). Just 1 question: The -exThreads thing is just extra threads, i jut wanna know how that hurts me (ill disable them for the test anyway). It also appears the name one just kinda dissapeared? Probably me switching something off

Heres the full log:

The -exThreads thing is just extra threads, i jut wanna know how that hurts me

Arma automatically enables all exThreads that make sense.