Page MenuHomePhabricator

Game won't launch after last exp 0.61 patch
Need More Info, NormalPublic

Description

Last week a new patch was released for Experimental 0.61. Since then the game won't start for me. With Steam open and task manager open steam says that the game is running for a few seconds and BEservice opens in taskmanager. It then closes and steam goes back to showing nothing. To begin with I could still play 0.60 but not experimental but since trying to fix this problem I can now no longer play even 0.60. Other steam games work, even arma 3 and I've done a lot of stuff to get the game working as its my main game I play. Here's a small incomplete list of what i've tried: Reinstalled windows, reinstalled steam, reinstalled dayz, reinstalled directX, reinstalled ALL C++ Visual redists, run the game, steam and battleye as administrator, downloaded Battleye manually, download msclouds.dll manually etc etc If I try to start the game through the taskmanager directly it says "No running instance of steam detected" althoug steam is running right there.
No problems show up in the event viewer. I Do have another problem I'm trying to solve with steam support. I cannot buy games through the steam store due to some SSL issue. This problem existed before this problem though and I could still play Dayz when it appeared.

I could probably try reinstalling again with some other windows dist but it seems kinda hopeless. I could also buy a new computer but ....really?

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 7
Operating System Version
sp1
Category
Game Startup
Steps To Reproduce

Press "play game" in steam

Additional Information

i7 4790k
16 Gb ram
ga-z87x-ud5h
MSI 980
Corsair Hx 750
Sandisk 480 Gb SSD

Event Timeline

Geez changed the task status from New to Need More Info.Nov 29 2016, 1:24 PM
Geez added a subscriber: Geez.

Hello Killawife and thank you for the report.
Are there any files present in the C:\Users\*username*\Documents\DayZ folder? And if so, can you try removing them and let us know if that had any effect? Also, did the 0.61 work for you prior to the patch you are mentioning?
Regards,
Geez

There used to be but since I've reinstalled windows they are gone. I did however, already try deleting it and it didnt work. 0.61 experimental worked fine up until last weeks patch. I was very surprised when it didn't start as I had changed nothing at all on my computer, no new software. no hardware, no updates to windows or anyhting. The whole thing is a mystery.

Geez added a comment.Nov 29 2016, 4:32 PM

Hello Killawife.
Could you try running the game again and then send us the contents of your C:\Users\*username*\AppData\Local\DayZ ?
Regards,
Geez

Ok, theres only two files and they are almost empty. I sent them as an attachment.

Geez added a comment.Nov 30 2016, 9:28 AM

Hello Killawife.
Those are files from the C:\Users\*username*\Documents\DayZ folder, the files which we require are located in C:\Users\*username*\AppData\Local\DayZ. Can you please upload those as well?
Regards,
Geez

Ah ok, I couldnt see them as I had "show hidden files and folders off". Here they are, I had to rar them as there was a fault message:

Geez added a comment.Dec 1 2016, 3:33 PM
This comment was removed by Geez.
Geez added a comment.EditedDec 1 2016, 4:00 PM

Hello Killawife.
When the BattlEye window appears, can you check if there are any error messages or blocked file messages before it shuts down?
Regards,
Geez

That was all at the time. Theres one mdmp file now. You see, I reinstall the game ten times a day to try to get it working so things change.

heres the files that are in the folder now:

There are no error messages or events in the event viewer. All that happens is that BEservice opens in taskmanager, runs for a few seconds and then it shuts down. Dayz.exe never opens and not steam_bootstrapper.exe either.
The only things related to dayz that runs are steam.exe, steamwebhelper.exe and another steamwebhelper.exe

Geez added a comment.Dec 1 2016, 4:27 PM

Hello Killawife.
If you havent done this before, can you try to delete all the files from C:\Program Files (x86)\Common Files\BattlEye and then run the game again ?
Regards,
Geez

I tried that right now. Same thing. I also tried disabling my firewall and virus protection but it only does the same thing.

This is so weird.

Geez added a comment.Dec 2 2016, 10:53 AM

Hello Killawife.
When you deleted the BE folder contents, did the BE install onto your computer again?
Regards,
Geez

No it did not.

Geez added a comment.Dec 2 2016, 5:09 PM

Hello Killawife.
Does the windows account you are using have administrator rights / is administrator?
Regards,
Geez

Have seen this on several PC's running Endpoint Security (symantec and ESET) only fix i have found is to disable the software during initial installation or complete removal of the software during initial install.

I am using symantec. I'll try disabling it. Thx for teh tip

OMFG it worked. The game now works. But now I dont have firewall any more :/

Still Thanks for the tip about symantec. I'll try to install some other version of it and see if it works.

Just add an exclusion for the game exe and you should be able to re-enable it... at least try anyway. You should do the same for your steam directory for AV, it helped my FPS tremendously.

Geez added a comment.Dec 5 2016, 10:25 AM

Hello again.
Glad to hear that the cause of the issue has been pinpointed. Killawife, please let us know which specific product from symantec you are using, so we can take a look if there is anything wrong on our side.
Regards,
Geez

Yes I am very happy to have foudn the casue of my problems. The product I was using is named "Symantec antivirus 2014". I have to say though that it is kinda strange that this should cause problems as I have been using it all the time AND playing Dayz. This is the first time it has caused any problems.

Geez changed the task status from Need More Info to Assigned.Dec 5 2016, 12:49 PM
Kouga added a subscriber: Kouga.Dec 5 2016, 6:38 PM

Hello everyone,

Having the same issue, but I am using Symantec Endpoint Protection. It doesn't yield anything trying to start DayZ with it turned off. Also verified the DayZ cache with it turned off to no avail. I'm literally without a clue what to do, I suppose I could add the DayZ folder to an exclusion list? But I have never done this before in my life of using this virus scanner/ firewall... Never had these issues before.

Regards,
Kou

I actually tried putting it in the exclusion list for the firewall and other things but it still didnt work. The only thing that worked was uninstalling symantec, steam and dayz and then reinstalling steam and dayz. Alos never had these issues til, just now.

Kouga added a comment.Dec 5 2016, 9:10 PM

Thanks for the response Killawife. Indeed I believe that will work, but I just don't want to uninstall my anti virus/ firewall. I'm kinda drawing the line there. There must be another solution? Otherwise I believe my DayZ adventures are at an end. Maybe I ought to try Miscreated...

I have to allow both the Steam web pages through my Virus checker/firewall and the ones from Dayz, otherwise nothing updates.

Appears Bit Defender is also identifying battleye as a Virus:

D:\steam\steamapps\downloading\221100\BattlEye\BEService.exe Gen:Variant.Barys.54401
Moved to Quarantine

Geez added a comment.Dec 7 2016, 5:16 PM

Appears Bit Defender is also identifying battleye as a Virus:

D:\steam\steamapps\downloading\221100\BattlEye\BEService.exe Gen:Variant.Barys.54401
Moved to Quarantine

Thank you, we will notify the BattlEye team about this anti-virus as well.
Regards,
Geez

I can confirm that uninstalling Symantec Endpoint Protection 14 will allow DayZ to launch again but only after DayZ is freshly deleted and reinstalled without Endpoint Protection installed. End point however does not quarantine or flag any files associated with DayZ or Battleye in my case.

Making exceptions of the DayZ directory and battleye directories doesn't yield results in my case either.

Only a total uninstall of Symantec End Point allows DayZ to work. reinstalling Endpoint stops DayZ launching.

This started happening last week after i updated Symantec Endpoint Protection 14. PRior t othat DayZ 0.61 Experimental was functioning.

I am using Symantec Endpoint Protection 12, and DayZ doesn't function for me in the exact same way as disjunctionreunion described. I am aware of the update to 14, I just haven't done it yet. Eitherway, it's not just 14. I think all Symantec versions went berzerk on BattlEye?

Sable added a subscriber: Sable.Dec 12 2016, 6:28 PM

Could you guys confirm that the issue is resolved with today's update?

Also, may I ask if anyone had this issue with any other Symantec software except Endpoint Protection?

Kouga added a comment.Dec 12 2016, 8:39 PM

Negative.

Before and after reinstalling DayZ, no life when trying to start it up.

Sable added a comment.Dec 12 2016, 9:41 PM

Negative.

Before and after reinstalling DayZ, no life when trying to start it up.

To clarify, I was referring to today's experimental update. Did you test on the experimental branch?

You were correct to clarify, after reinstalling I had forgotten to tune it to the experimental branch.

After tuning DayZ to the experimental branch, it works! I managed to log into a server and play around a bit. A surprising change after all the times of being denied to play, but a welcome one!

Thank you for the update and the heads up Sable.

This is why the Bug tracker exists well played

So it works with symantec now? I don't even dare try.

Sable added a comment.Dec 13 2016, 3:46 AM

So it works with symantec now? I don't even dare try.

Yes, it should. I'm wondering though, which exact Symantec software did you use? You mentioned "Symantec Antivirus 2014" before, but I didn't find any such product out there. Did you mean "Endpoint Protection" like everyone else?

Still had to open my virus checker and allow the page that downloads update, this only changed w/.61

Geez changed the task status from Assigned to Need More Info.Dec 13 2016, 9:34 AM

Hello again.
There have been some changes on the BattlEye side, does anyone still experience issues with BattlEye and Symantec on the current experimental branch?
Regards,
Geez

The program I was using is called : Symantec Enpoint protection 12.1.2.2015.

I am using Unhack me and windows firewall now instead. Works fine.

The program I was using is called : Symantec Enpoint protection 12.1.2.2015.

I am using Unhack me and windows firewall now instead. Works fine.

If you so desire, you can roll back to Symantec Endpoint Protection 12.etc.etc. DayZ works with it once more, for me.