Page MenuHomeFeedback Tracker

Bigs fps drops, Extreme lag, Game Crash (After 0.34.115106 Update)
Closed, ResolvedPublic

Description

Problem Full Description:

Both (0.34.115106 Stable Branch) and (0.34.115106 Unstable Branch Experimental)

"Apparently" for no reason after 10-20 minutes of normal gameplay the game starts to enter into a state of decline in terms of performance, initially due to a drop of framerate per seconds (graphics performance). But in the meantime that performance declines with the passing of time you may notice that the frames value not always coincide with the observed ingame-lag. For example 60-70 fps and the game still presents clear visual interruptions.

This means that the performance issue isnt related with the player machine(pc) performance.

To confirm this i can say that it is impossible that a so extreme drop of FPS can affect players that before the patch had good graphics performances (like me).

In the end, the lag becomes so hard that the game crashes and you are forced to terminate it manually, sometimes it stops working itselfs.

When the player rejoin any server the whole process restart from the beginning of this description. {F30151} {F30152} {F30153} {F30154} {F30155}

Details

Legacy ID
1315316602
Severity
None
Resolution
Fixed
Reproducibility
Always
Category
Performance
Steps To Reproduce

How To Reproduce The Issue:

There is no exact way to reproduce it because the bug does not happen by chance, but is connected to an equipped item or to the character ironically as if it were infected. So if "you have it" the the whole issue start (see description) instead if you dont have it, nothing will happens...

Additional Information

Addition Very Important Information:

THE ISSUE IS NOT PC PERFORMANCE RELTATED. (But better machine support major stress)

THE ISSUE IS NOT RAIN/WEATHER RELATED. (The weather may low your fps a little but have nothing to do with this issue)

So afterall i can say that this bug is related with the last (0.34.115106) update and is a CLIENT-SIDE issue or better to say: only happens to some players.

But for an unknown reason:

If a player "infected" with the bug is located in the geographical vicinity (ingame map) of others "non infected" players, causes them the same symptoms: huge fps drops lag and game freezes and crashes.

So the BUG can be transmitted if the players are on the same server, and if within a certain range, "which i think is the range that load/unload the 3d model of characters".

Another important observation is that the "non infected player" exposed to a "player infected by the bug" does not maintains the issue if the "original infected player" leaves the server or the load/unload range.

My final advice FOR DEVS (2 choice):

A) Avoid the bug

  • Return the "stable branch" to the previous stable version.
  • Maintain the unstable branch for further testing on the current version.

B) Potential Bug solution:

  • General cleaning of the database by deleting all the character data resulting in a deletions of all "infected" subjects/items.
  • Review the patch code.

My final advice FOR PLAYERS (2 possibilities):

A) Drop on the floor all items with flickering, white or other strange textures then go away from that items or change server, better if you drop that items on a dead body then hide it (for preventing that other player pick up bugged items).

B) If you are not having any flickering or bugged item in your inventory and you still have this issue its because some other player with these bugged items or an bugged item itself are in your vicinity like i said before. In this case you may change server or talk to this player and tell him to do the step A).

I hope this has been helpful.

Best Regards, StationMax

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
mick17 added a comment.Feb 9 2014, 3:24 AM

Can confirm this... Played most of the day and had no problems until my game started becoming unplayable: laggy jerky/freezing crashing. Huge drop in performance. I log in and within 30 seconds it's unplayable.

dio88 added a subscriber: dio88.May 8 2016, 4:59 PM
dio88 added a comment.Feb 9 2014, 2:44 AM

Same Issue like http://feedback.dayzgame.com/view.php?id=8262 ?
Same Problem. We was a group of 4 players. Every time i entered the game, and i spawned next to them, everyone has a FPS drop (-> till the game crashes). After some "troubleshooting" i joint the game and tried to reach the new position of my group. Everything workd fine, till i reach a "1km zone" of my group. If i step inside the "1km zone", every FPS drops. If i leave these zone, the FPS goes back to "normal"

fratzi added a subscriber: fratzi.May 8 2016, 4:59 PM
fratzi added a comment.Feb 9 2014, 2:22 AM

Video of micro lag and "flying" through a window. I don't know if this reflects this issue.

http://www.youtube.com/watch?v=dVTwzs4aNM0

pkactus added a subscriber: pkactus.May 8 2016, 4:59 PM

I was noticing just now, that the PAYDAY masks, (of which i have 2 ) have the flashing textures on them. Someone mentioned bad textures on bean cans, and i wonder. could it be perhaps a slot issue? or the item? I loathe to dump items to "test" .... any thoughts?

@delset Did you not read the notification when you bought the game or the one that pops up when you open the game.

"WARNING: THIS GAME IS EARLY ACCESS ALPHA. PLEASE DO NOT PURCHASE IT UNLESS YOU WANT TO ACTIVELY SUPPORT DEVELOPMENT OF THE GAME AND ARE PREPARED TO HANDLE WITH SERIOUS ISSUES AND POSSIBLE INTERRUPTIONS OF GAME FUNCTIONING.

so don't winge that the product code is incomplete or bugged that's the whole point of alpha to work out kinks and bugs and create a smooth enjoyable game-play experience

I solve the issue for me at least, I had some bean cans in my backpack with bad textures and when I removed them it stopped lagging. My friend had the same issue when he was near me but after I dumped the bad cans everything went back to normal but I guess it will start freezing again as soon as we encounter other players with the bad items.

Sooo check your equipment for flickering or white textures and if you or your friends has some bad items just dump them in the forest or in case of cans just open them with a can opener and the textures will reset.

Hope it helps

I was wondering, I have a lot of the :health packs: and ammo crates and protector yellow packs. Does the lag have a co-relation to those items?

Got the exact same problem, I play like 20 min and the frame rate drop brutally. Its really look like a increment variable that increase infinitely. I highly think its come from the GPU memory (the main memory doesn't look to suffer) and the CPU is fine. I was around Gvozdno (if that can help).

The tested machine:
I7-3610qm stock clock
8go ram
Nvidia 650m

tdc added a subscriber: tdc.May 8 2016, 4:59 PM
tdc added a comment.Feb 8 2014, 10:11 PM

I think it might have something to do with an item the "infected" player is carrying. It would be interesting to know what these players have on them; what hats, what guns, etc. I cruise along just fine at 70-80 FPS on my own, but when my friend with an M4 on his back joined up I was down in the teens on FPS. Eventually he found a Mosin and tossed the M4 and it seemed to get better after that, though there was still an occasional FPS drop. Could be another player was in our vicinity for a short time during the occasional drops.

Confirmed that this is an issue related to other players in the vicinity.

I was playing with one friend for a few hours with smooth FPS the entire time, but once we met up with another friend to add to our group, we ALL experienced serious FPS lag. The other player doesn't even have to be with in visual range either.

We tested the theory that it was caused by our friend who joined late by asking him to leave. Once his body disappeared from the server after log out, the FPS returned to normal. Right now the game is a slide show with extra players on the screen.

MaxZero added a subscriber: MaxZero.May 8 2016, 4:59 PM

Thank you for the advice Hatchet86 but i just have one GPU ;-).

Was a Multi GPU problem for me.
Had the exact same problem as you guys. I just disabled Nvidia SLI (2 x GTX580
now everything works perfect fine again. hope this will let some of you guys play the game over the weekend :D

Edit: it didn't completely solve the problem. But its way better now, at least the game doesn't crash anymoreand and i can play up to 10 min without lags.

Makke112's tipp is a good one! I also had those flickering/white textures on some of my ''old'' items. but i didn't test it yet.

But I created a Hardcore Char with no gear (newspawn) and played it for 2 hours now without any issues.

hope this helped

ZTDELTA added a subscriber: ZTDELTA.May 8 2016, 4:59 PM

VOTE UP! Had the same problem last night! Friend was having this problem, the moment I got to his location, me and my other friend also both froze up. It seems like a memory leak, how long it takes to freeze varies: my superpowerful desktop takes about 20minutes to freeze, for my friend on a laptop, its 5 minutes.

delset added a comment.Feb 8 2014, 6:20 PM

VOTE UP! VOTE UP! VOTE UP! The game is unplayable after 5-10 minutes! Major show stopper! This is what happens when you rush untested code to production!

Same here, after a few minutes frames braking down and finally freezes. Alt+F4 or Esc dosn't working. I have to shut down the game by the Task Manager. It occur on all servers. I noticed in the Task Manager that the used working memory was very high like 700 MB to 1,3 GB. Occuring after last patch on 2014-02-07 version: 0.34.115106

I have 16 GB RAM
Win 7 64 bit
ATI Radeon HD 5800 Pro

Uldreg added a subscriber: Uldreg.May 8 2016, 4:59 PM

I do agree that this lag seem to be related to proximity of other players . I was fine when I was playing on my own, but when I've joined group of my friends after about 10 minutes we all started having a massive frame drop to about 10FPS. We've tried to spread around/different servers, but this didn't fix the problem and at the moment game is unplayable for us.

My PC:

Windows 7 Proffessional x64
Intel i7 2600K
Geforce 770 GTX
8GB RAM

Also experiencing this. Frame rates usually in low teens when normally 60-70 on "High" graphical setting.

i7-2600 @ 3.4GHz
8GB RAM
Nvidia 560ti in SLI

Didn't ever happen before last patch, so must be directly related.

Same with me... directly at connection regardless of server the FPS fluctuates between 7 and 12 with drops to 1 FPS. Freezes and manual termination of game were common. Interaction with Zeds was almost suicide and caused character damage due to games freezes of up to 5 seconds. The games is basicly unplayable now.
Character was fully kitted out and the two servers played had 1 and 0 additional players hosted.

pad77 added a subscriber: pad77.May 8 2016, 4:59 PM
pad77 added a comment.Feb 8 2014, 6:08 AM

same issue here

i5 3450 @ 3.10Ghz
AMD Radeon HD 7800 Series
8 GB DDR 3 Ram

before patch - 50-60fps
after - 20 or less

Can confirm as well. For me it's not even after 10-20 mins, it's virtually every time I connect, I start playing at about 1fps seemingly. I'm running on a quad-core, 8gbRAM, modern GPU, so I know it's not my end of things (none of the aforementioned are even close to max capacity, so...)

Hey guys!

This meanie has been fixed internally and will be patched in the next update!

Thanks goes to everyone who helped us fix this issue. Kudos!

http://forums.dayzgame.com/index.php?/topic/173224-hotfix-changelog-stable-branch-035115188/ [^]

Loobiz added a subscriber: Loobiz.May 8 2016, 4:59 PM

My characthers are not "infected", before this parch i use to play the game at very high graphics and there was no problem.
Now i get at random moments this fps drops and lag issues, i see players teleporting from one place to another, my characters movements are super lagged, and the random sounds are now crazy! I hear the zombie-reloading-drinking all the time!

As I said this is on random moments, sometimes works good sometimes is sh*t.
PD: My game have never crashed yet.

NO_FEAR added a subscriber: NO_FEAR.May 8 2016, 4:59 PM

I seem to start out OK but after a half hour the FPS starts to degrade down to individual frames with 2-3 second skips. I'm all kitted up with ammo and stuff in containers in my pack on the west coast. I have a camo painted Mosin, ammo box full.

Core i7 quad OC to 4.5 MGz, ASUS MB, 32 Corsair Vengeance DDR3 mem, 2 7950 ATI GPU with 6 GDDR5 in Crossfire with latest drivers.

they've mentioned on the twitters, that they are quite aware of an fps drop and memory leak, they're patching on wednesday -

Itchypants, Kactina here, I also had a point where 2 slots were "filled but blank" only to restart (wait the 400 seconds) and realize there was "2 empy pop cans in those slots" and to remove them i had to put to hand, then put a box in my hand to unhold them. then slot them off to vacienity

Thank you very much adroc!

Soris, could you please upload the aforementioned files?

It would really help us in identifying the issue.

Thank you!

http://speedy.sh/WQsQ6/DayZ.rar
here are my data.
My problem were the items with flickering/white textures on it. when i threw them away and ran out of the area, frames came back to normal and everything worked fine

Windows 7 64-Bit
X58 SLI E758
3 GTX285 FTW in SLI (Using SLI Profile to activate)
6GB triple channel Ram
Intel Core i7920 @ 3.35GHZ
RAID 0 2 WD Black 500GB=1TB

Start out with 100+FPS then slowly/gradually reaches 0FPS and locks, also note: my GPU usage is in line with the FPS, EX: 20FPS = 20%GPU Usage
Using Precision to monitor

NOTE: this happens even when I'm the only person in server

Dump File:
http://williamwendland.com/William-FB-DayZ.zip

R834 added a subscriber: R834.May 8 2016, 4:59 PM
R834 added a comment.Feb 12 2014, 8:33 AM

A patch is supposed to be coming out today in a couple of hours

Thanks a LOT for the files, guys. This should be enough for now.

Looks like the test servers are up, so maybe soon.
Happy Looting!

Also if you are experiencing crashing then please could you also send us the dump files;

DayZ.RPT
DayZ.bidmp
DayZ.mdmp
debug.txt (if you have this)

This is so we can investigate the issue and solve it.

Thank you very much

fr3nchy added a subscriber: fr3nchy.May 8 2016, 4:59 PM

any words on improvement yet ? its been 4 days now and still cant play..

Windows 8 64-bit
MSI GT70 laptop
i7-3630QM
8GB RAM
nVidia GTX 680M / 4GB GDDR5

Similar problem to those mentioned above. Started out with acceptable performance. Noticed some flickering textures on my M4 attachments. Grouped up with a couple of friends. Performance rapidly started to tank, going as low as 2 FPS at times, and intermittently freezing for several seconds.

Config, RPT and dumps:
http://speedy.sh/7zY8t/illformed-DayZ-logs.zip

Flicker added a subscriber: Flicker.May 8 2016, 4:59 PM

What if i have a flickering item but i dont experience any fps drops apart from looking at cherno/electro :D ?

Calibre added a subscriber: Calibre.May 8 2016, 4:59 PM

01/02/2014 20:16 Application Error Faulting application name: DayZ.exe, version: 0.32.114.557, time stamp: 0x52e0221e
Faulting module name: DayZ.exe, version: 0.32.114.557, time stamp: 0x52e0221e
Exception code: 0xc0000005
Fault offset: 0x005b33d4
Faulting process ID: 0xc64
Faulting application start time: 0x01cf1f7ff9742a6a
Faulting application path: E:\Dir\Steam\steamapps\common\DayZ\DayZ.exe
Faulting module path: E:\Dir\Steam\steamapps\common\DayZ\DayZ.exe
Report ID: ba661fc6-8b7d-11e3-bee4-00044b17a124
Faulting package full name: 
Faulting package-relative application ID:

let's cross our fingers.

Fidla added a subscriber: Fidla.May 8 2016, 4:59 PM
Fidla added a comment.Feb 11 2014, 6:55 PM

Since last update (0.34.115106) I have long fps drops connected with more memory usage (I have 8 GB) and flickering textures (usually sprayed items like sprayed parts of M4). With my nVidia Fermi VGA (1GB N560GTX-Ti) on my game quality settings (LOW-NORMAL) I have usually aprox 60fps, but after 20-40 minutes fps decrease under playable minimum - 30 fps. Near 15 fps are problems connected with long freezes - Dayz stop working message or recomendation of stoping dayz for heavy RAM usage.

I think, that long duration fps drops are caused by bug in memory management and they have connection with loading certeain item textures (usually sprayed items).

My solution is restart game (clear textures from memory) and reconect to diferent server. And i have 60fps back for at least 20 min.

wait wait wait. so is it a good thing when my whole player and zombies have texture flickering even after re spawn. (caused by this.... twice )

Sharp added a comment.Feb 10 2014, 1:11 PM

Hi I have the same problem before updating the game ran at 65fps and now after a few minutes played FPS starts to fall to 10-20fps.

MY PERSONAL COMPUTER
Benq xl2420t 120Hz
Intel Core i5-2500K
ASUS P8P67-M
Hdd: 1T
8192MB
NVIDIA Gigabyte GTX570
Seasonic 620W Bronze

http://www.speedyshare.com/eEk5a/DayZ.rar

http://speedy.sh/A3eZh/DayZ-rpt.rar -RPT

Hey Sharp,

please, can you upload the dump files specified above?

Thank you!

Had some lag and saw flickering textures on some bean.
Ate the beans...logged out and chose different server in my next visit.

Soris added a subscriber: Soris.May 8 2016, 4:59 PM

http://speedy.sh/qgmP2/DayZ.rar

I can't find DayZ.RPT DayZ.bidmp DayZ.mdmp
I just send files form documents folder.

mMn added subscribers: stock, mMn.May 8 2016, 4:59 PM
mMn added a comment.Feb 10 2014, 4:27 PM

http://speedy.sh/a9DUG/DayZ.zip

Intel I7 3770K @stock
ASRock Z77 Extreme4-m
4x4GB Mushkin Silverline (PC3-10666)
ASUS GTX770-DC2OC
Windows7 Pro x64

ih8 added a subscriber: ih8.May 8 2016, 4:59 PM
ih8 added a comment.Feb 10 2014, 6:45 PM

language="English";
adapter=-1;
3D_Performance=93750;
Resolution_Bpp=32;
Resolution_W=1920;
Resolution_H=1080;
winX=16;
winY=32;
winW=800;
winH=600;
winDefW=800;
winDefH=600;
refresh=60;
Render_W=1920;
Render_H=1080;
FSAA=2;
postFX=4;
GPU_MaxFramesAhead=1;
GPU_DetectedFramesAhead=1;
HDRPrecision=8;
lastDeviceId="";
localVRAM=2131443712;
nonlocalVRAM=2147483647;
vsync=1;
AToC=0;
SWLayersCount=0;
PipQuality=0;
PPAA=0;
Windowed=0;

I do think there is some voodoo here. I was having this exact issue on empty servers. Hard to say it was due to proximity to 'gliched characters'. I had flashing inventory before crash. No flashing inventory upon restart. Inventory was flashing just before crash.

I have only had this issue today. I was playing just fine for a few hours today, then it started. I had to quit out. I could no longer play.

I had pre-patch character during this patch. No issue. I had SKS during this patch. No issue. I had painted M4 during this patch. No issue.

I did notice one thing that was new and it does coincide with the onset of this issue. That is about drinking cans of pop. When I did not put them into inventory, but just drank them from the world, I began having inventory issues. I seemed to have empty and unusable slots in my inventory. Upon relogging, I saw that my inventory was full of empty pop cans with a remaining total of 0% contents. They were what was in the unusable inventory spots. They had become invisible.

I will say that drinking from the environment is also a habit that I only just began today. I realized it was possible and began hauling those babies back. Then the glitch.

So that is my addition to the voodoo.

Apparently, the game of my friend did crash at exactly the same time as my game crashed. A server switch did lead to no further crashes.

yeah, i'd have to agree with wickedinsane, and some others - it is not all servers that show intent on killing you pr. memory leak - but those that does, omfg! took a screenshot of my task manager after running with 1-2 fps for a minute, and damn.. dayz was sucking up more than 1.2 million KB of memory

Similar problem.also i see zombies change texture for 1 sec turning grey.
windows 7 home premium 64 bit
intel q6600 2.4 ghz, 4g ram,

http://speedy.sh/jmz5E/Jonny.rar

bronney added a subscriber: bronney.May 8 2016, 4:59 PM

Confirmed it's the texture drinks. Found info here:
http://forums.dayzgame.com/index.php?/topic/172193-fps-with-the-latest-patch/#entry1756970

As soon as I drank all the bug drinks all went back to normal fps including big cities. you got this Dean? :D

I can't remember if I expirienced crashes but I had some major FPS drops while playing on several different servers.

Here's the files. https://www.dropbox.com/s/mtg6xv5s3gsgmqa/DayZ.7z

I confirm that for me, opening canned beans that had bad texture do the trick.

i7 2670qm cpu 2,20 ghz
GeForce GT 555M
8 gb ddr3
Before patch about 25-30 fps on very low, after patch unplayable after 5 min

http://speedy.sh/qgmP2/DayZ.rar

Game start freezing and fps drops if i have some items with blure textures (food or soda badly damage quality(you can find a bank and everything will be fine, but after relog starts frieze,but not always, the law lags food we could not fully understand) or MagPool details for M4). my friends and I noticed that if you repaint this parts friezes disappear, but after reloging texture blurred again and game starts freezing.

after 20 to 5 minuts my pc crashes and if i am near other players they start to lag and as soon as i leave they are fine.
15 meg internet
gtx770 4gb
intel i7 4770k
8 gb ram
windows 8.1
running of ssd

before the patch i ran the game on the High graphics setings with about 60-80 fps (all other setings were at normal such as rendering, antialising, FSAA

This comment was removed by Dwarden.
Dwarden added a subscriber: Dwarden.Fri, Dec 6, 5:42 PM