Page MenuHomeFeedback Tracker

ARMA 3 BLACK SCREEN AFTER LAUNCH
Need More Info, WishlistPublic

Description

Arma 3 stops responding after initial launch. All i see is the splash and then
a black screen. I have attempted a reinstall since this issue and still no fix.
I have cleared all my cached files and removed all player profiles. Yet to no
avail it wont work. Any assistance is appreciated.
I have attached my rpt and mdmp files for reference. {F25390} {F25391} {F25392}

Details

Legacy ID
3419550387
Severity
None
Resolution
Open
Reproducibility
N/A
Category
Game Crash

Event Timeline

crashtm edited Steps To Reproduce. (Show Details)Jan 12 2015, 12:24 AM
crashtm edited Additional Information. (Show Details)
crashtm set Category to Game Crash.
crashtm set Reproducibility to N/A.
crashtm set Severity to None.
crashtm set Resolution to Open.
crashtm set Legacy ID to 3419550387.May 7 2016, 8:05 PM
crashtm edited a custom field.
crashtm added a subscriber: crashtm.May 7 2016, 8:05 PM

Checked system Event Viewer and found this error:

Faulting application name: arma3.exe, version: 1.36.128.579, time stamp: 0x5480321d
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000096
Fault offset: 0x0254fad9
Faulting process id: 0x1abc
Faulting application start time: 0x01d02df351cb255c
Faulting application path: E:\Archives\OLD PROGRAM FILES\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe
Faulting module path: unknown
Report Id: 9b3dd687-99e6-11e4-b92b-98588a037175

As well as this was the launch parameters that i would normally run with arma 3 before this problem happened:

-enableHT -maxMem=3072 -maxVram=2048 -noBenchmark -noLogs -noPause -noSplash -world=empty

Hello,
it seems that either some of your drivers or DirectX might be corrupted, could you please reinstall these?

I have the same issue. I also read about more people with te same issue. This all happend after the last update, never had any crash issues before that. Both dev as stable version with the same result.

edit: I just reinstalled DirctX from the arma folder and still get a complete freeze after the intro black screen.

I ran the arma diagnose (see attachment) and only see some arrors of the dlc.

ManagerConfig()
c:\w\dev\futura\lib\steammanager\dlcmanager.cpp(73)(func: Steam::Dlc::DlcManager::UpdateDlcItems) [AssertRLS] MainThread=2656 Game: 107410, DLC index:0 of 9 AppId of the DLC is invalid:
c:\w\dev\futura\lib\steammanager\dlcmanager.cpp(73)(func: Steam::Dlc::DlcManager::UpdateDlcItems) [AssertRLS] MainThread=2656 Game: 107410, DLC index:8 of 9 AppId of the DLC is invalid:

Edit2: I switched to Arma3Legacy136 and that is working fine.

I have the same issue as well, after the 1.38 update. Sometimes it'll work if i just run arma3.exe from the ARMA 3 folder without any startup params.

B00tsy,
please create a new ticket for your problem, it does not look like it's connected to this one. Thank you.