Page MenuHomePhabricator

Analoge Throttle problems
New, NormalPublic

Description

When I am in a helicopter or plane and open the Esc menu, Blufor tracker or chat, my throttle/collective goes to zero and air frame falls out of the sky. I have tested with and without mods and problem persists, advanced flight model is not affected by this and works as expected. leading me to believe its a BI problem or something wrong on my end. I have tried to find a solution to this problem to no avail.

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Operating System Version
1709
Category
Gameplay
Steps To Reproduce

have collective set to analog (under Helicopter Movement)

load in MP server

jump in helicopter and hover

press Esc or /

helicopter falls to ground

Additional Information

found this issue mentioned here: https://feedback.bistudio.com/T65252, but the link supplied is out dated.

Quoted Text
rogerx
We also keep loosing throttle (or thrust) when text chatting. Sometimes even when viewing the main map.
Sounds like whenever the text window is opened, or sometimes the map and other GUI windows; joystick events are blocked, ignored or dumped.

de
opened seperate issue for this: http://feedback.arma3.com/view.php?id=20645

Event Timeline

fire-39_1 created this task.May 2 2018, 7:35 PM
Wulf added a subscriber: Wulf.May 4 2018, 1:15 PM

Hello.

I tested this on a dedicated server and everything seems alright. Could you create a test mission and upload it here?

Thank you.

Also supplied a video of the issue.
https://youtu.be/PJcSru4zdu4

Any update on this? can this be replicated by anyone?

Wulf added a comment.May 11 2018, 3:50 PM

Tried it with your test mission. Still I am not able to reproduce this issue. Could you please upload a screenshot of the control layout in your Helicopter movement?


I use a Logitech extreme 3D pro and by default the collective up reads as negative input, and the down collective reads as positive. When I unbind the analog settings the problem goes away.

Woulff added a subscriber: Woulff.EditedTue, Jan 8, 8:12 PM

I have this same issue. Anytime I try to put down a marker, open chat, or hit escape, the aircraft throttles down for helicopters and max throttle for planes. As fire-39_1 stated, it appears to be related to analog binding. I reverse thrust for helicopter and plane.

Anyone have a fix for this?

nope, I have not found a work around for this. Still having the issue.

It doesn't appear anyone has event looked at this issue. I'd appreciate it if we at least got a response. Even if it was just to say it won't get fixed.