Crash on bad_module_error
Reviewed, NormalPublic

Description

While playing without mods on MP dedicated servers and in the new Tank showcase, game hangs and crashes randomly.
After the crash a Windows dialog tells me that the cause was "bad_module_info" and the arma troubleshooter signals a : "0xC0000005 - STATUS_ACCESS_VIOLATION" type error.
Report log in the additional information tab.

Launcher version: 1.5.144637
Game version: 1.82.144647
Branch: main

Details

Severity
Crash
Resolution
Open
Reproducibility
Random
Operating System
Windows 10 x64
Category
General
Steps To Reproduce

Occurs randomly, can't reproduce.

Additional Information

Ema_90 created this task.Apr 16 2018, 4:10 PM
Vitdom added a subscriber: Vitdom.Apr 17 2018, 11:51 AM
Wulf changed the task status from New to Reviewed.EditedApr 18 2018, 1:18 PM
Wulf added a subscriber: Wulf.

Hello.

Hmm this being random will be hard to pinpoint, we will see what can be done.

Ema_90 added a comment.May 4 2018, 9:11 PM

Another crash of the same type, this time happened while opening the map and closing it fast on multiplayer.

Ema_90 added a comment.May 4 2018, 9:23 PM

Oh, another crash. This time I was still playing multiplayer, but I was standing still, not giving inputs.

Ema_90 added a comment.May 5 2018, 1:56 PM

Still the same, in multiplayer, while running.

Vitdom added a comment.May 6 2018, 1:04 PM

Arma3_x64_2018-05-04_21-12-08 and Arma3_x64_2018-05-05_13-45-15, the last two crash reports appears related.
Can you verify game files and tell us if any files were re-downloaded?
Check for updated drivers.

You appear to be crashing often, do you also crash on other MP servers and missions?

Ema_90 added a comment.May 6 2018, 5:54 PM

I'm crashing mostly in the MP, I usually play EUTW and Sa-Matra KOTH. Both 5/4 and 5/5 crashes were in the EUTW servers.
The problem is that I get the crash even on SP, but sometimes the launcher crashes when generating a log file too!

I've veriified the game cache and no downloads are made.
Drivers are up to date, from bios to peripherals. Windows update is active and no updates are pending.

This is infact not a probem with arma! Its a problem with windows 10 after the creation update. I had the issue myself, and the only way to fix it was to install an earlier version of windows. I ended up getting a free version of windows 8. Infact arma 3 runs better in Windows 8 than 10. The game dosent crash when you tab out, and i seem to get a better framerate.

This is infact not a probem with arma! Its a problem with windows 10 after the creation update. I had the issue myself, and the only way to fix it was to install an earlier version of windows. I ended up getting a free version of windows 8. Infact arma 3 runs better in Windows 8 than 10. The game dosent crash when you tab out, and i seem to get a better framerate.

I've tried to run ARMA in windows 8 compatibility mode, but it doesn't stop the crashing. I'd rather keep the crashes and keep the devs updated on the issue, so that it can be fixed ARMA-side.

Here we go again, crash on Multiplayer while driving a vehicle and going back and forth from map.

Ema_90 added a comment.EditedMay 31 2018, 2:32 PM

And again, I was on MP standing still and scanning around when stuttering arrived and the game locked up crashing.

Ema_90 added a comment.EditedJun 4 2018, 9:32 PM

This time I was in Sa-Matra King of the Hill, in the AO with OK frames per second, just locked up and crashed with a STATUS_ACCESS_VIOLATION like the other instances. This time, windows didn't warn me of the bad_module_error. I just verified the game cache and it literally downloaded a file 735,2 MB big.