Page MenuHomeFeedback Tracker

Every time I boot Arma 3 up, it crashes my entire PC and a hard restart is required.
Need More Info, WishlistPublic

Description

I boot up the game, it reaches the final Arma 3 logo and then crashes my PC, I can get no response at all.

At one point it did get through to the menu but then looked as if it was loading a mission file straight away and crashed again. If you look in crash file it shows it's trying to load a mission on Stratis. {F25467} {F25468} {F25469} {F25470}

Details

Legacy ID
1190879953
Severity
None
Resolution
Open
Reproducibility
Always
Category
Game Crash
Steps To Reproduce

Just boot the game up under any conditions.

Additional Information

Have tried many different solutions such as -nobenchmark and re-installing Direct X run-time.

Event Timeline

diegotristanUK edited Additional Information. (Show Details)
diegotristanUK set Category to Game Crash.
diegotristanUK set Reproducibility to Always.
diegotristanUK set Severity to None.
diegotristanUK set Resolution to Open.
diegotristanUK set Legacy ID to 1190879953.May 7 2016, 8:10 PM
Bohemia added a subscriber: danph7.Jan 27 2015, 1:50 PM

Second file upload is full RPT file.

Hello,
Thank you for reporting the issue.
We need crash dump files from this folder to analyze your problem.
C:\Users\<Name>\AppData\Local\Arma 3\
Can you upload somewhere in winrar package, please?
Archive smaller than 5000 KB can be attached directly to the ticket. For bigger archives, please use some free sharing service and post link here.

How to find correct crashdump file:
Try to make the crash happen
Look into crashdump folder
Upload crashdump with latest date in name (crashdump is rpt + bidmp + mdmp file with same name). Please try to provide as many crashdumps as possible, it helps us investigating the problem in a big way.

Thank you.

http://feedback.arma3.com/how-to-user.html

I'm not able to find anything but RPT files in AppData/Local/Arma3.

I have several RPT files and Battleye, MPmissionscache, players, squads and steampreviewcache folders. Also, one debug text file.

That is all I can see, am I doing something wrong?

It looks like the crash does not come from Arma's engine. Could you please verify your game's content?
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Please also consider trying to start the game with parameter -world=empty. Game will not load a world into its memory in this case.

Yes, one file failed to validate and was re-acquired. This has been the case since the issue started occurring. Every time I have validated the files, which is quite a few times, it finds a dodgy file.

Could you please try to turn off your antivirus before the next validation? It is possible that it (or other software) deletes or changes part of the game.

Ok, will do. Just to let you know, I tried -world=empty, it got to telling me that the helicopters DLC was released, I moved the cursor around for about 2 seconds and then my whole PC crashed.

Ok, with antivirus off, I validated the file again. It got to the main menu and then crashed to desktop, but did not crash my entire pc.

Did the crash create rpt + bidmp + mdmp files?

Yeah, I have added them to this ticket, I have put one file in 7zip if that's ok.

For some reason, your system is repeatedly restarting your display device. This can be caused by many aspects (both software and hardware). It can also be caused by overclocking CPU or GPU (even by a manufacturer)and does not affect only Arma but many other games.
Here are some useful tips:
http://forums.bistudio.com/showthread.php?147598-Endless-DXGI_ERROR_DEVICE_REMOVED-Crashes

Hmmmm, does not affect any other games for me. I have clocked 210 hours on Arma 3 and no problems before. Any specific ideas that could help?

Try to find out if you have not installed some software recently that could be causing any trouble to the graphic adapter or driver.

Also make sure that your PC is not overheating.

Will a factory reset of my system cure this? Or is there a way I can lower some of the settings for the game before I boot it up?

Bohemia added a subscriber: Bohemia.May 7 2016, 8:10 PM

1 Maybe some profile in control panel of graphic software was created or some registry tweaks for improwe performance?
2 I would reinstall video driver and restoring its setting to default,install all required software (which steam is installing after first run game).
3 Did you run game befora on that resolution or changed it? Maybe your monitor or graphic is not suporting resolution?
4 Pagefile is on or off?

Page file is set to automatic, I changed it to 8192mb, this did not fix the issue. Is there any way of checking/changing resolution before I boot it up?

Yes, go to My documents\arma 3 and find open arma3.cfg (with notepad)

I have the same issue. And it has been like this off and on since alpha, without any hardware changes between it not working and sometimes working. No other games or programs are acting like this. So please don't close this thread without a solution, like you have done with all the other tickets with the same issue. THIS IS A REAL PROBLEM! So stop blaming it on overclocking, overheating or other software because the few times it has been working I have logged 115hours. From all I have seen this seems to only affect AMD GPU's. I am running a HD7970. Sometime before christmas it was suddenly working, and with all kinds of mods and peripherals as well. Now it won't even show me a splash screen without my computer crashing.

danph7 added a comment.Feb 2 2015, 5:40 AM

I get the same fucking shit. It is an ISSUE that needs to be fixed. Stop pushing it off as if its not your problem ARMA 3 devs...damn that is the worst IT response. It is so damn unprofessional

Seems it's not just me then. I have done everything within my knowledge/power to resolve this issue, but have had no luck at all.

I just want to play the damn game, it was the game I played the most.

P.S,
To the guy above, I am not using an AMD gpu, i'm running a GTX 760.

danph7 added a comment.Feb 2 2015, 4:05 PM

I have a 780TI with a 2600k CPU. I have also tried everything and tried every parameter. It is an issue within the game that needs to be resolved...

Hmm, lets just stay easy ok? nerves will not fix it.
On your position i would test it w/ and w/out mods, but remember when game is pathed with newest path, mods require the same. So update all mods, try dev build and normal, use -winxp command on comandline, try to use sweetFX mod (it helps in severall cases mainly beacuse of .dll files) and write back what you discover.

Looks like more people have same issues as i have.

Well, start uploading mini dumps from Windows so that a developer could look into the reason why Windows crash. It could be a driver issue or hardware that is triggered by something Arma does. As you know, an application should not be able to crash Windows no matter what it does, unless there is a problem with the driver or hardware. Good thing here is that I guess Arma developers are in contact with Intel, Nvidia and AMD and should be able to find a solution if there is a common issue.

Right, I played in dev build. It didn't crash my PC this time, I just got a black screen and it said there was no HDMI signal to my monitor. Does that shed anymore light on what it could be?

danph7 added a comment.Feb 7 2015, 9:13 PM

You want to know what it is? It is a DX11 failure issue. The computer thinks you have physically removed the video card which causes the driver to crash. ARMA 3 software side is the culprit

danph7 - please dont try be smarter that Game and system designers, this isnt the same fault as on your example. This is hapening beacuse game is turning to mode that you monitor is not suporting. I recomend to check what reolution is seted in My documents\arma 3 ( open arma3.cfg with notepad). There you should find many options you can disable, Also after changes, mark this file as read-only, so tha game cannot change your options. BE SURE YOU SETTED RIGHT RESOLUTION SUPPORTED BY YOUR MONITOR!. Try to install other video drivers and directX libraries. ( http://www.microsoft.com/en-us/download/details.aspx?id=6812 ) . In windows use command "run" and type "dxdiag" (enter), click "yes" and in poped up window, check all bookmarks. There should be in all of them writed "No problems found", if there is'n, you will found the issue

This is my config file, does anything look wrong?
steamLanguage="English";
language="English";
detectedAdapterId=0;
detectedAdapterVendorId=4318;
detectedAdapterDeviceId=4485;
detectedAdapterSubSysId=275714270;
detectedAdapterRevision=161;
detectedAdapterBenchmark=91;
displayMode=0;
winX=16;
winY=32;
winWidth=1024;
winHeight=768;
winDefWidth=1024;
winDefHeight=768;
fullScreenWidth=1920;
fullScreenHeight=1080;
refresh=60;
renderWidth=1920;
renderHeight=1080;
multiSampleCount=1;
multiSampleQuality=0;
particlesQuality=0;
GPU_MaxFramesAhead=1000;
GPU_DetectedFramesAhead=3;
HDRPrecision=8;
vsync=0;
AToC=0;
cloudsQuality=0;
pipQuality=2;
dynamicLightsQuality=2;
PPAA=0;
ppSSAO=4;
ppCaustics=0;
tripleBuffering=0;
serverLongitude=-2.1833;
serverLatitude=53;
class ModLauncherList
{
};
ppBloom=1;
ppRotBlur=1;
ppRadialBlur=1;
ppDOF=1;
ppSharpen=1.0034335;

danph7 added a comment.Feb 8 2015, 6:42 PM

"This is hapening beacuse game is turning to mode that you monitor is not suporting."

No, I have checked and the resolution is correct with the correct refresh rate. Also, if I am not mistaken the game doesn't list unsupported monitor resolutions anyway..I dont think its a problem with the video card drivers. I have tried many and they all result in the same thing. I did dxdiag right off the bat.. Like I said it is an issue within the Arma 3 software...Just like the sound channel issue Arma had that they finally accepted was their fault instead of to keep suggesting things to the end user like it is a client side issue..Now all we need is for that to be recognized so we can stop playing the roundabout game.

I am using the GIGABYTE Nvidia GeForce GTX 580 and I have had CTDs with Arma 3 for quite some time, and again I read the same responses as I see here when I addressed the issue here: GPU overclocked? Overheating? They also told me my DirectX drivers crashed, and I had NO PROBLEMS with other games whatsoever.

For me it turned out to be the core frequency of the graphic card. It was overclocked by the manufacturer and for some reason made the game crash to desktop. I fixed it with finding out the default core frequency of my graphic card and using MSi Afterburner to switch the core ferquency back to the default setting.

Now, this sounds all great and all, but ALL OVER THE INTERNET there are guides and explanations as how to make sure a game can still continue to function AFTER DirectX drivers crash. In fact all that is needed at such times is a restart of the DirectX drivers. This has been said and explained on here over and over but still nothing is done with this information. I find that rather odd really.

Yes, this is an issue with Arma 3. Denying it by saying it's someone's hardware is totally nonsense, because it's happening to MANY people with DIFFERENT graphic cards. That does mean something, does it? So to all the fanboys out here, I like the game too now it finally runs for me, but this is a serious issue and needs a little more than just the regular your hardware is overclocked responses people are getting. The fact remains many manufacturers overclock by default, so isn't it about time game devs (not just Bohemia) take this into account and code their games in such a way they can deal with it?

StJimmy added a subscriber: StJimmy.May 7 2016, 8:10 PM

Do you get blue screen of death? If yes can you say what the error code is?

Here are some examples and there are more than that.
https://msdn.microsoft.com/en-us/library/windows/hardware/hh994433%28v=vs.85%29.aspx

The error code comes pretty low on the screen.

Hmmmm, I don't know what my core frequency should be at. I had a GTX 660 in my system, but my PC was sent away for repairs and got an upgrade to a GTX 760. Arma 3 has worked for months after changing GPUs though.

@diegotristanUK: On the following page it says the base frequency is 980: http://www.nvidia.com/gtx-700-graphics-cards/gtx-760/

I am not sure if that is the default core frequency though. For me it was mentioned on the box the graphic card came in.

Let me know if you found it and running the card on the default core frequency actually helped fix anything.

I tried to set the core frequency to 980, but I just got a white screen and had to restart the PC. This issue still persists.

So... I just testet the game again, same crash. Reinstalled it, same crash.
And instead of listing the ticket as need more info, it would be great if you acctualy tried to figure out what is wrong. I don't think I have been able to play for about 9 months now. And having to hard reset my pc everytime i try isn't realy healthy for my system. Some feedback from BIS on what they are doing to address this issue (if anything) would be much appresiated.

Bi have started to be very lazy (no offence). You still have this problem? It llok like they dont look fol older tickets

Also try to change Display Mode to 1 and 2 - it will force windowed mode and change :
GPU_MaxFramesAhead=1000;
GPU_DetectedFramesAhead=3;

to :
GPU_MaxFramesAhead=1;
GPU_DetectedFramesAhead=1;

1000 is unsupported number!

If BI doesn't seem to be that serious about issues like this anymore than maybe all of us should stop playing Arma 3 and return to Arma 2.

Maybe that will make them act on things.

StJimmy removed a subscriber: StJimmy.May 31 2016, 6:25 PM