Page MenuHomeFeedback Tracker

Server not loading mods unless folder name = meta name
Closed, ResolvedPublic

Description

After the 1.12 update servers do not load mods correctly if the @folder_name it's not exactly the same as the name on meta.cpp file causing problems on hundreds of workshop mods, server and server owners.

The server should load any mod independent of the folder name, folder name should not be used for mod check due to different special characters used on mod names, character limitation without a par file, and allowing server owners to organize their mod folder names as they desire.

Allowing @WorkshopModID on the folder name it's a perfect check if you want to force mod check on folder names.

Please fix/revert back this decision as it makes no sense looking at how Arma loads the mods without this restriction and it's affecting thousands of servers.

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Operating System Version
Any
Category
General
Steps To Reproduce

Add any mod from workshop and just rename the folder to @WorkshopModID for example and server will not load it.

Event Timeline

defused created this task.Wed, Apr 21, 6:36 AM
Geez changed the task status from New to Assigned.Wed, Apr 21, 11:56 AM
Geez changed the task status from Assigned to Acknowledged.Wed, Apr 21, 3:14 PM
Geez added a subscriber: Geez.

Hello defused.
We have confirmed the issue and we are working on solving it as soon as possible.
Regards,
Geez

Thank you, waiting on development and issue fix.
Regards

Geez added a comment.Tue, Apr 27, 3:16 PM

Hello again.
A fix has been deployed on the experimental version. Please check and let us know if there are any issues still.
Regards,
Geez

(Hopefully I can just comment on here cause I've never used this site before so sorry in advance!) @Geez I know the experimental version patch for it was just put out today (which I'll have to test eventually), but do have any idea on when it might come to the regular stable version after testing from experimental is over? Again, sorry in advance! Haha.

Geez added a comment.Wed, Apr 28, 3:13 PM

Hello Calibre145.
The hotfix has been released just now, please let us know if there are any problems still.
Regards,
Geez

Geez closed this task as Resolved.Tue, May 4, 4:51 PM
Geez claimed this task.