Page MenuHomePhabricator

Vehicle progress so far
Acknowledged, NormalPublic

Description

Spent a few days in EXP to review progress with vehicles. This is our second round in EXP .61.
What we found:

  1. While not perfect, the vehicles can be driven past each other without launching or pushing
  2. Improvement on truck is dramatic, most improved vehicle

However, we found the following:

  1. Sound is insanely loud still and the 4X4 still will go into the buzz, silence, buzz at a rapid rate when going fast
  2. Serious memory problems, (that is my opinion), occur when driving vehicles for a long distance. I can start out at 26-27 FPS, (normal game FPS is 25-35). However, as I drive, the vehicle gets buggier and my FPS slowly drops to 3-4 FPS and the vehicle becomes uncontrollable. My friend's computer drops to the same FPS driving and his video memory is three times as much as mine and his system memory is double mine. He was driving the truck and zombies were floating above it, walking through it, etc. Our progress was limited to 8km even down hill. I tried driving and it refused to go over 5KM with all the zombies on it - it was faster running

Restarting my computer improved the FPS, but it would drop as I drove. Its like the server is not clearing out junk of the player's computer/graphic card memory and it seems the zombie animation on vehicles makes it worse.

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Operating System Version
Win 10
Category
Game Physics
Steps To Reproduce

Drive a vehicle, the longer it is driven, the worse it drives with glitches and desync.

Additional Information

Event Timeline

Geez changed the task status from New to Need More Info.Feb 27 2017, 12:43 PM
Geez added a subscriber: Geez.

Hello DesertRat and thank you for the report.
The second issue you are mentioning is a known issue and it is scheduled for a fix. We are also aware of several sound issues tied to the hatchback, however, could you try to describe the first issue in more detail? Does the issue occur only in third person view or in first person view also? And by buzz silence buzz silence, do you mean that the volume keeps changing or that the sound completely stops and then starts playing again? Would it be possible for you to record a video of the issue?
Regards,
Geez

This is the same sound problem, but in the sedan.

Geez added a comment.Mar 8 2017, 10:36 AM

Thank you DesertRat.
Have you experienced the sound issue also when the fps is not as low as in the video?
Regards,
Geez

Hi, as my FPS gets worse the longer I play, you are looking at the video I took before logging off. Actually, it started when my FPS was twice what it was at the end, (I know, 2 X 8 is only 16 FPS). In looking at the video, the sound matches the desync I am experiencing, so it could be that.

Geez changed the task status from Need More Info to Acknowledged.Mar 9 2017, 10:21 AM

Hello DesertRat.
Our internal testing has revealed that the cutting off sound is indeed related to the low fps in vehicles.
Regards,
Geez