Page MenuHomeFeedback Tracker

Sound Crash when using VOIP
Acknowledged, NormalPublic

Description

Sound Driver crashes after using in game voice chat.

Arma 3 and Project Argo are not recognizing the new / rebooted sound driver after a crash / change of the audio source. This is requiring you to restart the game.
Menu option to select audio device (feature request) would help a lot and would give access to more possibilities.

Example:
Video: https://youtu.be/gcJveNsixlw

Crash (0:24): https://youtu.be/gcJveNsixlw?t=23s
Driver reboots (0:27): https://youtu.be/gcJveNsixlw?t=27s

Details

Severity
Major
Resolution
Open
Reproducibility
Sometimes
Operating System
Windows 10 x64
Operating System Version
10.0.14393
Category
VON
Steps To Reproduce
  1. Join any server
  2. Communicate with other players using VOIP
  3. While other players are speaking quickly press the Push-to-talk button multiple times
  4. Keyboard driver reboots, sound driver reboots
  5. Sounds are no longer hear able.
Additional Information

Sound Driver: HyperX 7.1 Audio: Micosoft 10.0.14393
Project Argo: 0.74
Sound crashes occurred ~7 times in 8h active playtime.
RPT (from the video): http://pastebin.com/MikDykbi

Event Timeline

Yoshi_E created this task.Feb 3 2017, 12:48 AM
millhauz changed the task status from New to Need More Info.Feb 3 2017, 11:39 AM
millhauz added a subscriber: millhauz.

Hello
Would you be so kind and provide more info according to this link? : https://feedback.bistudio.com/w/ft_argo_howto/general/
I just tried it few times and those headphones are working fine. Will keep an eye for this issue but I still need more info - for example the dxdiag

millhauz claimed this task.Feb 3 2017, 11:39 AM
Yoshi_E added a comment.EditedFeb 3 2017, 7:00 PM

Sorry for leaving out dxdiag in my first post.
This time i was able to reproduce it within 20min (Event Time 18:36:42).

Virtual Audio lines were not in use.
It seems that not only the sound driver, but all USB Devices were forced to reset (at least 3 USB controller involved)

Possible that a to large "audio package" is causing an Error within the USB controller? According to USBLogView the USB HUB the Headset is attached to, is the first one to reset.
Will investigate using the on board usb ports for headset.

Project Argo Version: 0.74.139907
New RPT:

or http://pastebin.com/zemybpgD
dxdiag: or http://pastebin.com/1jeEkQAZ
UsbLogView: or http://pastebin.com/t6bkFQiB or

Yoshi_E changed Category from Sound to VON.Feb 5 2017, 11:29 PM

Seems to be linked to https://feedback.bistudio.com/T122017
Merging is not possible, stuck in loading:

millhauz added a comment.EditedFeb 9 2017, 1:30 PM

I've merged those issues. Currently investigating, but im unable to reproduce this using the HyperX headset for now.

Yoshi_E added a comment.EditedFeb 9 2017, 9:49 PM

Found some additional information:
It seems to effect multiple players at once:
During the same round another player reported to become "deaf" at the same time as i did.

Also its hard to reproduce on purpose: it usually just happens when you are communicating with other players at some point...

Sadly I have no clue about your sound engine, but maybe these errors are related?
These errors appear at least once before the sound crashes (but it might be just me, as those erros are almost always there)
(as in the previously attached RPT):
18:29:54 Sound: Error: File: a3\sounds_f\characters\crawl\metalplate_crawl_4.wss not found !!!
18:29:54 Sound: Error: Multi-stream: Load failed, stream a3\sounds_f\characters\crawl\metalplate_crawl_4.wss not found !!!

The problem still occurs on a regular basis, VOIP is unusable.

Would it be possible to add a "Audio reset" key command for the Engine, that is similar to the "FLUSH" command, that is used to reset the Graphik driver? An option in the Audio settings tab maybe ("Select Audio Device")?
Arma 3 / Argo does not recognize the audio driver, after plugin in and out, it would resolve many audio issues.
Should I make a feature request for that in the Arma 3 section?

Hello. Thanks for additional info.
I´m still not able to reproduce it but the investigation continues. Also we will discuss your request.

Yoshi_E added a comment.EditedMar 23 2017, 5:51 PM

This time not only the sound, but the hole game crashed when i used VOIP.
Though I would assume the reset of all I/O inputs was the cause of the crash, so the dumps probably dont contain any value able data


This Error Message says:
"The Command in 0x00000000000CE0Da72 pointed at Ram at location 0x000000000000000. The task "read" could not be executed in the Ram.
Click "Ok" to close the application."

https://youtu.be/crJX6T9CaDY

Yoshi_E added a comment.EditedApr 2 2017, 10:34 PM

I did some research, checked all drivers+controllers for updates, followed this guide:

https://www.sysnative.com/forums/hardware-tutorials/3906-usb-driver-reset-usb-ports-power-state-reset.html
(i did only step 1 and 2 of the guide)
and it seems uninstalling any faded devices / deactivating them did the job.

I played multiple games using VOIP without problems.
I would not consider the issues as resolved, but it seems that following that guide prevents the driver crash.

Hi. I´m happy for you. Lovely research. Also thanks for the information ;).