Page MenuHomeFeedback Tracker

Crash on saving/opening a mission in the editor
Acknowledged, NormalPublic

Description

ArmA 3 crashes whenever i click on the "save" and/or "open" icons in the 3D Editor. The game closes and i get the "0x00005 STATUS_ACCESS_VIOLATION" Errorreport. I tried with mods and vanilla, validated the game multiple times over steam and reinstalled it. Nothing helped so far. I seem to be alone with that problem and its a mayor one, since i really enjoy playing self made missions with friends.

Details

Severity
Crash
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Category
Eden Editor
Steps To Reproduce
  1. Open game
  2. Open editor
  3. click "save" or "open"
  4. game crashes
Additional Information

The Spanish Inquisition is my Steam alias. I got a discussion on the topic but so far nothing helped...

Event Timeline

Jawsh added a subscriber: Jawsh.Jan 19 2017, 3:54 AM

Nobody expected the Spanish Inquisition to submit a crash report.

@SpanishInquisition, try the below possible solutions one-by-one:

Try all of the possible solutions listed for 0xC0000005 - ACCESS_VIOLATION on the Arma 3 Unusual process exit article on the Bohemia Interactive Community Wiki.

Try making a backup of your Arma 3 and Arma 3 - Other Profiles folders in Documents. Once they are backed up you can delete your original Arma 3 profile that is inside of Arma 3 or Arma 3 - Other Profiles. If that does not help than you can restore the profile(s) from backup.

If the issue persists after trying all of the above possible solutions then use the Arma 3 Launcher to prepare a troubleshooting report and then upload the report to the feedback tracker for the developers to review.

For issues regarding Arma 3 you can file a troubleshooting report, also via an action available in the option menu in the upper right corner (gear icon)

Be sure to upload the whole report file. If the report file will not upload directly to the feedback tracker then try uploading to a free file sharing service such as Dropbox, Microsoft OneDrive, Google Drive, Mega.nz, and so forth, and then link to the report file.

Alwin claimed this task.Jan 19 2017, 10:45 AM
Alwin changed the task status from New to Reviewed.

Hi, @SpanishInquisition

Can I ask you about your crash report, plz?

Try to delete your profile folder (create a backup) a try to start the game.

The file yourprofilename.vars.Arma3Profile must be deleted.
Path: C:\Users\*username*\Documents\Arma 3

Thanks for the ideas so far!
I updated my graphics and deleted my profile. Both didnt fix it. It still crashes when i try to save/open. I played multiplayer recently on a server and it works fine. No troubles. I just cant save or load missions in the editor...

The crash just says ArmA was closed unexpectedly and shows this one line: 0xC0000005 - STATUS_ACCESS_VIOLATION plus the 3 links to the feedback tracker etc.

Since it still doesnt work after I tried some other things here and there I did the troubleshooting and here is the report I saved:

Alwin changed the task status from Reviewed to Acknowledged.Feb 1 2017, 12:01 PM
Alwin added subscribers: cup, Ace.Feb 1 2017, 12:03 PM

The culprit is most likely somewhere here.

-mod=C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@cup Terrains - Core;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@CBA_A3;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@Arma Enhanced Movement;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@PLP Urban Packs- Barriers and Fences;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@Em_Buildings;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@cup Terrains - Maps;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@cup Weapons;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@cup Units;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@Ace;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@cup Vehicles;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@IFA3LITE;C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Worksh

Disable all mods, update or repair them and load them one-by-one.

Ok i unloaded all the mods and repaired every single one just to be sure... Except the handful of mods from Armaholic or elsewhere but they are not listed with the culprits. After repairing the mod i loaded it and did so with all the mods. Then i started the game as always and it still crashes.

02.02.2017 22:59:36 - Laden von Datei 'C:\Windows\SysWOW64\rlls.dll' blockiert

I discovered this line in the Battleeye section of the launcher afterwards. It just says "loading of data ´C:\Windows\SysWOW64\rlls.dll´ blocked.

Not sure if that got something to do with it. I also saw that some maps that were in CUP terrains before now are split into another seperate CUP mod. I got that one too now maybe since the problem seems CUP related...

Still thanks for the effords and i hope we can tackle this annoying mystery someday.

For some time now i also have troubles with the game Insurgency... Seems like since it got the BattleEye Update... The Framerate drops all the time. I noticed the same in the ArmA 3 AND even the ArmA 2 editor. Dont know if its related but ill try to get BattleEye fixed or something or nothing.

Reinstalling Insurgency fixed the framerate stuff. Im now reinstalling Arma again which means also redownloading all the mods. If its not working then ill be ready to give it up...

Why does stuff like this happen 700+ hours in? Couldnt the damn game crash before i liked it and got invested by it?

Reinstalled it and launched it without mods and the framerate in the editor is very good now. still crashes though so no progress.

That random update fixed it.