Page MenuHomeFeedback Tracker

Arma3Tools.exe refuses to open
Closed, ResolvedPublic

Description

It occurred after setting up my P:/ drive. Once the compiling of the addons was complete, I wasn't able to access Arma3Tools.exe -- by either opening it via Steam, opening it via the file directory in /common/, on the P:/ drive, or running it as an administrator. It pops up in Windows Task Manager for a few moments with 2,908kb, then disappears. {F27891} {F27892}

Details

Legacy ID
132171842
Severity
None
Resolution
Fixed
Reproducibility
Always
Category
Tools
Steps To Reproduce

Everything seemed to work fine prior to setting up my P: drive. I'm also unable to do a Arma3Tools_diag_retail due to it crashing after "Loading Hotfix Information" with:
"ERROR: Invalid argument/opinion - 'Library\SteamApps\common\Arma' -
Type "FORFILES /?" for usage.

which it doesn't let me type, after a few moments it spams a bunch of text and instantly closes. Screenshot of spam is linked

Event Timeline

ChaplinLIVE set Category to Tools.
ChaplinLIVE set Reproducibility to Always.
ChaplinLIVE set Severity to None.
ChaplinLIVE set Resolution to Fixed.
ChaplinLIVE set Legacy ID to 132171842.May 8 2016, 1:34 PM

Hello,

The error of the diagnostic script is strange. However, for what I can see, it seems something went wrong at the installation level. Could you please try to verify the integrity of the local file and start it again from Steam?
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335&l=english

Also, try to move/delete the file called settings.ini (in the root directory of the tools).

Thanks for the speedy reply,

It appears that 9 files failed. Not sure how that came about, but it is able to stay open again! I'll remember that step next time. I'll give it a couple of hours and see if anything changes, but for now it looks good!

Good to read :)