Page MenuHomeFeedback Tracker

Universal flashlight lost on M4A1 after logging out then logging in
Need More Info, NormalPublic

Description

Now I'm sure. This is the third time it happens to me.
I proudly find an Universal Flashlight, my goal is to attach it to my favourite weapon : the M4A1. So I attach a 9V battery to the Universal Flashlight, then I attach this one to my rifle.
It's OK, it perfectly works… until it's time to diner (what a mess).
So I log out and close the DayZ client.
A few minutes later, when I log back in the game, the night has Fallen. What is my first reaction ? Turn my rifle flashlight on. So I left click on my mouse and… Nothing happens. Hum...
Maybe the battery is dead ? Let's see that.
W... wait… WHAT !? My Universal Flashlight isn't attached to my favourite rifle anymore !
Then I lost one 9V battery and one Universal Flashlight. :(

I'll never log out for diner anymore !

Details

Severity
Feature
Resolution
Open
Reproducibility
Always
Operating System
Windows 10 x64
Operating System Version
17763.253
Category
Inventory
Steps To Reproduce
  1. Attach a 9V Battery to an Universal Flashlight
  2. Attach this Universal Flashlight to a M4A1 rifle
  3. Exit the game
  4. Log back in the game
  5. The Universal Flashlight and the 9V Battery have disappeared
Additional Information

I don't know if it only disappear when game is exited or if it does when you log out from a server and log back in the same or another server too.

Event Timeline

Kafune235 updated the task description. (Show Details)Jan 17 2019, 9:19 PM
Geez changed the task status from New to Need More Info.Jan 18 2019, 1:31 PM
Geez added a subscriber: Geez.

Hello Kafune235 and thank you for the report.
We have tested the issue you have described, however, we have been unable to reproduce the issue so far. Have you experienced this issue on a community server? Was there any noticeable desynchronisation going on the server?
Regards,
Geez

Hello Geez,
I was on an official server. There were not any noticeable desynchronisation going on this server.
However I can precise something : the rifle had ATOG Scope, Standardized Suppressor, M4 Buttstock OE and a fully loaded 30rd Standardized Mag attached to it. (I Don't precise the M4-A1 Rail Handguard because without this one the flashlight can't be attached).
Moreover i'm not actually pretty sure the flashlight disapears 100% of the times.
May this helps you ?
Regards,
Kafune235

Flamberg added a subscriber: Flamberg.EditedSun, Jan 27, 11:54 AM

V 1.0.150192
Vanilla server

I experienced a similar issue with MP5(SG5).

I had all attachments on it (Flashlight, ATOG Scope, SG5K folding buttstock, SG5K compensator, SG5K Rail Handguard, Pistol Suppresor, Magazine). After a logout/login, the flashlight was gone.

Could it have something to do with the fact that the flashlight is attached via the Rail component (handguard in case of MP5)?