Page MenuHomeFeedback Tracker

BIS_fnc_UnitCapture doesn't copy to clipboard on Linux port
New, NormalPublic

Description

After unit capture has been stopped, the option to hit "F1" presents to copy capture data to clipboard. For me this does not copy anything to clipboard, there is nothing copied to clipboard.

Details

Severity
Major
Resolution
Open
Reproducibility
Always
Operating System
Linux x64
Operating System Version
Antergos Linux (arch linux branch) 4.20.6
Category
Other
Steps To Reproduce

Create trigger with rec = [unitname, 60] spawn
BIS_fnc_UnitCapture; and start game from editor. Play as the unit you will capture.
Hit "Esc" when finished and "F1" to copy data to clipboard when prompted.

Attempt to paste to any application on desktop.

Additional Information

No text from within ARMA pastes to any application outside of it on Linux, I speculate.
I understand that desktop integration is very hard on linux, but.. here's the bug.

thanks

Event Timeline

cface79 created this task.Aug 9 2018, 5:31 PM
cface79 changed Severity from Minor to Major.Feb 6 2019, 4:36 PM
cface79 changed Operating System Version from unamre -r 4.17.8-1-ARCH to Antergos Linux (arch linux branch) 4.20.6.

It has now been SIX(!) months after I encountered this bug, and it has not even been acknowledged by dev-team.
I will try to catch BI's attention on social media, because this bugtracker is clearly just ignored.

The linux build is released as an experimental build. Check out their announcement regarding this:
https://dev.arma3.com/ports

Specifically:

It is not guaranteed these ports will ever graduate from their experimental betas. We will be evaluating the popularity of the betas and any issues they may reveal.

Mondkalb removed a subscriber: Mondkalb.Feb 6 2019, 4:43 PM
cface79 added a comment.EditedFeb 7 2019, 12:38 AM

That is an idiotic reply.

I really shouldnt feed the trolls, but the ports work f*cking fine, and as far as me have had great support all along the way.

It just annoyed me that developers have taken six months, and still havent replied to this bug when a bug tracker is meant to serve as a point of contact between developers and users.

Its pretty simple, if it is as you say then close the report and say " ports no longer supported" so I can move on with my life.

Its kind of condescending when someone comes along and says: "Oh, haven't you read this?" when I have, many times, but still feel that this could be fixed.

Sorry for my overreaction but I get really annoyed when people bring up thing that Im already fully aware of and have my own expectations about what I can do with the port and how much support I can get.