Steam Overlay and Hotbar icon Desync
Closed, ResolvedPublic

Tags
Subscribers
Assigned To
Authored By
TeamDeer, May 27 2017

Description

Hi, noticed 2 things today and yesterday.

  1. When launching the x64 bit DayZ the steam overlay only shows up half the time it seems completely random when it shows up or not. Game restart does fix the problem sometimes.
  1. Sometimes the item icons in the hotbar show one thing but when going to inventory they show something else. We'll assume putting rags in slot 1 and shotgun in slot 2 when you hit 'show items' it shows it incorrectly sometimes what was in the slot previously or something like that. However, going to inventory it shows the correct icons. Usually dropping everything fixes the problem. It's happened to me on several occasions across different servers and lives but I can't seem to reproduce it or find out what's causing it.

Details

Severity
Minor
Resolution
Open
Reproducibility
Random
Operating System
Windows 10 x64
Category
General
Additional Information

.62 exp

Geez changed the task status from "New" to "Need More Info".Jun 2 2017, 3:38 PM
Geez added a subscriber: Geez.

Hello TeamDeer and thank you for the report.
The issue with inventory/normal quickbar showing items incorrectly is known and scheduled for a fix. As for the Steam overlay issue, are your graphic drivers up to date?
Regards,
Geez

Hi Geez,

Just checked. As of the current build x64 bit won't show the steam overlay, however, the 32 bit client works just fine. Using a evga gtx 1080 and the drivers are up to date (version 382.33)

Geez added a comment.Jun 6 2017, 11:47 AM

Hello TeamDeer.
Are you using some kind of third party program that uses an overlay? (Such as Fraps, Shadowplay and such). If so, can you try disabling it and let us know if there is still an issue with the overlay not working?
Regards,
Geez

Hi Geez,

Just double checked that I have no programs running that cause the overlay to not work. Under some testing disabling the steam overlay fps option (in steam options) does allow the overlay to work on 64 bit but once it's enabled again the overlay does not load.

Geez added a comment.Jun 7 2017, 11:40 AM

Hello TeamDeer.
So does that mean the overlay does not work for you on the 64bit only when steam overlay fps is enabled?
Regards,
Geez

Geez added a comment.Jun 16 2017, 4:50 PM

Hello TeamDeer.
We have been testing the issue internally, however we were unable to reproduce the issue so far. If it is not an issue, can you provide us with a dxdiag file from your computer?
Regards,
Geez

Hi Geez,

The issue has pretty much disappeared on the stable branch. I have found out that it was MSI Afterburner program which was interfering with the experimental version. Something about how it links with the steam FPS counter i'm guessing. Turning off MSI afterburner seemed to have fixed the problem I guess. Might want to look into what's causing the issue with that program and DayZ. Otherwise thanks for the help team. :)

Geez added a comment.EditedJun 19 2017, 2:33 PM

Hello TeamDeer and thank you for the update.
Can you try the following and let us know if that had any effect on the issue with MSI Afterburner?

  • Navigate to C:\Program Files (x86)\RivaTuner Statistics Server\ProfileTemplates
  • Find a file called "global" in the folder
  • Open the file and find InjectionDelayTriggers = IGO64.dll line
  • Add ",GameOverlayRenderer64.dll" (without the "") behind the IGO64.dll
  • The line should look like this now: InjectionDelayTriggers = IGO64.dll,GameOverlayRenderer64.dll
  • Save

Regards,
Geez

Hi Geez,

That worked perfectly. I can now use the steam overlay with the MSI afterburner software. Perhaps this info should be readily shared with the community incase they are experiencing the same problem. Thanks team.

Geez added a comment.Jun 21 2017, 3:06 PM

Hello TeamDeer.
Glad to hear that this has resolved your issue. In that case I am going to close this ticket, but feel free to submit another one in case you encounter any issues in the future. Also, as you have suggested, we are going to post the information on our forums so other players experiencing the issue can try to resolve it through these steps.
Regards,
Geez

Geez closed this task as "Resolved".Jun 21 2017, 3:06 PM
Geez claimed this task.

Add Comment