The new checVisibility command is great, but since it essentially functions in a very similar fashion to the existing intersection commands I'd like to suggest that its arguments order be made similar as well, as the current implementation is slightly confusing.
Current: [ignoreObj, lod] checkVisibility [startPosASL, endPosASL];
Suggested: checkVisibility [startPosASL, endPosASL, lod, ignoreObj1, ignoreObj2];
Adding a second ignored object would be extremely helpful and fall in line with existing commands. Since usually commands like these are checking between to known objects, checkVisibility only being able to ignore one means that sometimes using getPosASL on the object or eyePos will return 0 visibility due to the check point being INSIDE one of the objects.